summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/vigra/files')
-rw-r--r--media-libs/vigra/files/1.7.1-automagicness.patch53
-rw-r--r--media-libs/vigra/files/1.7.1-fix-nosetest.patch26
-rw-r--r--media-libs/vigra/files/1.7.1-fix-tests.patch11
-rw-r--r--media-libs/vigra/files/1.7.1-gcc4.6.patch40
-rw-r--r--media-libs/vigra/files/1.7.1-hdf5.patch35
-rw-r--r--media-libs/vigra/files/1.7.1-numpy_doc.patch27
-rw-r--r--media-libs/vigra/files/1.7.1-png-1.5.patch36
7 files changed, 0 insertions, 228 deletions
diff --git a/media-libs/vigra/files/1.7.1-automagicness.patch b/media-libs/vigra/files/1.7.1-automagicness.patch
deleted file mode 100644
index e2a518c45e03..000000000000
--- a/media-libs/vigra/files/1.7.1-automagicness.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -urN vigra-1.7.1.old/CMakeLists.txt vigra-1.7.1/CMakeLists.txt
---- vigra-1.7.1.old/CMakeLists.txt 2011-03-31 19:32:42.000000000 +0200
-+++ vigra-1.7.1/CMakeLists.txt 2011-03-31 19:39:51.000000000 +0200
-@@ -38,16 +38,32 @@
- ##################################################
-
- INCLUDE(VigraFindPackage)
--VIGRA_FIND_PACKAGE(TIFF NAMES libtiff)
--VIGRA_FIND_PACKAGE(JPEG NAMES libjpeg)
--VIGRA_FIND_PACKAGE(PNG)
--VIGRA_FIND_PACKAGE(FFTW3 NAMES libfftw3-3)
-+
-+option(WITH_TIFF "Enable tiff support" ON)
-+option(WITH_JPEG "Enable jpeg support" ON)
-+option(WITH_PNG "Enable png support" ON)
-+option(WITH_FFTW3 "Enable fftw support" ON)
-+option(ENABLE_DOC "Build documentation" ON)
-+if(WITH_TIFF)
-+ VIGRA_FIND_PACKAGE(TIFF NAMES libtiff)
-+endif()
-+if(WITH_JPEG)
-+ VIGRA_FIND_PACKAGE(JPEG NAMES libjpeg)
-+endif()
-+if(WITH_PNG)
-+ VIGRA_FIND_PACKAGE(PNG)
-+endif()
-+if(WITH_FFTW3)
-+ VIGRA_FIND_PACKAGE(FFTW3 NAMES libfftw3-3)
-+endif()
- IF(WITH_HDF5)
- VIGRA_FIND_PACKAGE(HDF5)
- ENDIF()
-
--FIND_PACKAGE(Doxygen)
--FIND_PACKAGE(PythonInterp)
-+IF(ENABLE_DOC)
-+ FIND_PACKAGE(Doxygen)
-+ FIND_PACKAGE(PythonInterp)
-+ENDIF()
-
- IF(WITH_VIGRANUMPY)
- FIND_PACKAGE( VIGRANUMPY_DEPENDENCIES )
-@@ -267,10 +283,4 @@
- MESSAGE( STATUS " vigranumpy will NOT be installed" )
- ENDIF()
-
--IF(NOT TIFF_FOUND OR NOT JPEG_FOUND OR NOT PNG_FOUND OR NOT FFTW3_FOUND OR
-- NOT HDF5_FOUND OR NOT VIGRANUMPY_DEPENDENCIES_FOUND)
-- MESSAGE( STATUS "" )
-- MESSAGE( STATUS "Consider setting DEPENDENCY_SEARCH_PREFIX to find missing libraries" )
--ENDIF()
--
- MESSAGE( STATUS "---------------------------------------------------------" )
diff --git a/media-libs/vigra/files/1.7.1-fix-nosetest.patch b/media-libs/vigra/files/1.7.1-fix-nosetest.patch
deleted file mode 100644
index b75b8698e403..000000000000
--- a/media-libs/vigra/files/1.7.1-fix-nosetest.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/include/vigra/noise_normalization.hxx b/include/vigra/noise_normalization.hxx
-index 8758cde..344a601 100644
---- a/include/vigra/noise_normalization.hxx
-+++ b/include/vigra/noise_normalization.hxx
-@@ -583,6 +583,9 @@ void noiseVarianceListMedianCut(Vector1 const & noise, Vector2 & clusters,
- for(unsigned int k=0; k < clusters.size(); ++k)
- {
- int k1 = clusters[k][0], k2 = clusters[k][1]-1;
-+
-+#if 0 // turned the "internal error" in a postcondition message
-+ // for the most likely case
- std::string message("noiseVarianceListMedianCut(): internal error (");
- message += std::string("k: ") + asString(k) + ", ";
- message += std::string("k1: ") + asString(k1) + ", ";
-@@ -590,6 +593,11 @@ void noiseVarianceListMedianCut(Vector1 const & noise, Vector2 & clusters,
- message += std::string("noise.size(): ") + asString(noise.size()) + ", ";
- message += std::string("clusters.size(): ") + asString(clusters.size()) + ").";
- vigra_invariant(k1 >= 0 && k1 < (int)noise.size() && k2 >= 0 && k2 < (int)noise.size(), message.c_str());
-+#endif
-+
-+ vigra_postcondition(k1 >= 0 && k1 < (int)noise.size() &&
-+ k2 >= 0 && k2 < (int)noise.size(),
-+ "noiseVarianceClustering(): Unable to find homogeneous regions.");
-
- double diff = noise[k2][0] - noise[k1][0];
- if(diff > diffMax)
diff --git a/media-libs/vigra/files/1.7.1-fix-tests.patch b/media-libs/vigra/files/1.7.1-fix-tests.patch
deleted file mode 100644
index 5f236f76f9ac..000000000000
--- a/media-libs/vigra/files/1.7.1-fix-tests.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -urN vigra-1.7.1.old/test/utilities/test.cxx vigra-1.7.1/test/utilities/test.cxx
---- vigra-1.7.1.old/test/utilities/test.cxx 2011-09-04 17:13:53.362610527 +0200
-+++ vigra-1.7.1/test/utilities/test.cxx 2011-09-04 17:27:55.772600423 +0200
-@@ -33,6 +33,7 @@
- /* */
- /************************************************************************/
-
-+#include <cstddef>
- #include <iostream>
- #include <iterator>
- #include "unittest.hxx"
diff --git a/media-libs/vigra/files/1.7.1-gcc4.6.patch b/media-libs/vigra/files/1.7.1-gcc4.6.patch
deleted file mode 100644
index e8959860035a..000000000000
--- a/media-libs/vigra/files/1.7.1-gcc4.6.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- a/include/vigra/sifImport.hxx 2011-04-10 09:36:12.735845000 -0500
-+++ b/include/vigra/sifImport.hxx 2011-04-10 09:36:41.805845002 -0500
-@@ -58,6 +58,7 @@
- #include <cstring>
- #include <vector>
- #include "vigra/multi_array.hxx"
-+#include <cstddef>
-
- namespace vigra {
-
-@ -43,6 +43,7 @@
- #include <set>
- #include <list>
- #include <numeric>
-+#include <stddef.h>
- #include "mathutil.hxx"
- #include "array_vector.hxx"
- #include "sized_int.hxx"
-diff -baur vigra-1.7.1.old/include/vigra/sifImport.hxx vigra-1.7.1/include/vigra/sifImport.hxx
---- vigra-1.7.1.old/include/vigra/sifImport.hxx 2010-12-03 17:40:34.000000000 +0000
-+++ vigra-1.7.1/include/vigra/sifImport.hxx 2011-01-28 00:23:31.000000000 +0000
-@@ -57,6 +57,7 @@
- #include <fstream>
- #include <cstring>
- #include <vector>
-+#include <stddef.h>
- #include "vigra/multi_array.hxx"
-
- namespace vigra {
-diff -baur vigra-1.7.1.old/include/vigra/multi_iterator.hxx vigra-1.7.1/include/vigra/multi_iterator.hxx
---- vigra-1.7.1.old/include/vigra/multi_iterator.hxx 2010-12-03 17:40:34.000000000 +0000
-+++ vigra-1.7.1/include/vigra/multi_iterator.hxx 2011-01-28 00:23:31.000000000 +0000
-@@ -41,6 +41,7 @@
- #define VIGRA_MULTI_ITERATOR_HXX
-
- #include <sys/types.h>
-+#include <stddef.h>
- #include "tinyvector.hxx"
- #include "iteratortags.hxx"
-
diff --git a/media-libs/vigra/files/1.7.1-hdf5.patch b/media-libs/vigra/files/1.7.1-hdf5.patch
deleted file mode 100644
index b930656a0e97..000000000000
--- a/media-libs/vigra/files/1.7.1-hdf5.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff -urN vigra-1.7.1.old/include/vigra/random_forest/rf_visitors.hxx vigra-1.7.1/include/vigra/random_forest/rf_visitors.hxx
---- vigra-1.7.1.old/include/vigra/random_forest/rf_visitors.hxx 2011-03-31 19:32:42.000000000 +0200
-+++ vigra-1.7.1/include/vigra/random_forest/rf_visitors.hxx 2011-03-31 20:15:28.000000000 +0200
-@@ -860,6 +860,7 @@
- ArrayVector< int> indices;
- OOB_Error() : VisitorBase(), oob_breiman(0.0) {}
-
-+#ifdef HasHDF5
- void save(std::string filen, std::string pathn)
- {
- if(*(pathn.end()-1) != '/')
-@@ -869,6 +870,7 @@
- temp[0] = oob_breiman;
- writeHDF5(filename, (pathn + "breiman_error").c_str(), temp);
- }
-+#endif // HasHDF5
- // negative value if sample was ib, number indicates how often.
- // value >=0 if sample was oob, 0 means fail 1, corrrect
-
-@@ -1056,6 +1058,7 @@
-
- /** save to HDF5 file
- */
-+#ifdef HasHDF5
- void save(std::string filen, std::string pathn)
- {
- if(*(pathn.end()-1) != '/')
-@@ -1074,6 +1077,7 @@
- temp[0] = oob_per_tree2;
- writeHDF5(filename, (pathn + "ulli_error").c_str(), temp);
- }
-+#endif // HasHDF5
- // negative value if sample was ib, number indicates how often.
- // value >=0 if sample was oob, 0 means fail 1, corrrect
-
diff --git a/media-libs/vigra/files/1.7.1-numpy_doc.patch b/media-libs/vigra/files/1.7.1-numpy_doc.patch
deleted file mode 100644
index b112395e8a6b..000000000000
--- a/media-libs/vigra/files/1.7.1-numpy_doc.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -urN vigra-1.7.1.old/vigranumpy/docsrc/CMakeLists.txt vigra-1.7.1/vigranumpy/docsrc/CMakeLists.txt
---- vigra-1.7.1.old/vigranumpy/docsrc/CMakeLists.txt 2011-09-04 17:13:53.362610527 +0200
-+++ vigra-1.7.1/vigranumpy/docsrc/CMakeLists.txt 2011-09-04 17:18:03.282607530 +0200
-@@ -1,4 +1,4 @@
--IF(PYTHON_SPHINX)
-+IF(PYTHON_SPHINX AND ENABLE_DOC)
- # vigranumpy documentation generation using sphinx
- IF(DEFINED VIGRANUMPY_DOCDIR)
- MESSAGE(SEND_ERROR "VIGRANUMPY_DOCDIR already defined! Please delete from Cache.")
-@@ -33,7 +33,7 @@
- ${VIGRANUMPY_DOCDIR}
- COMMENT "Generating vigranumpy documentation")
-
--ELSE(PYTHON_SPHINX)
-+ELSE(PYTHON_SPHINX AND ENABLE_DOC)
- # no vigranumpy documentation if sphinx not available
- ADD_CUSTOM_TARGET (doc_python
- ${CMAKE_COMMAND} -E echo
-@@ -41,7 +41,7 @@
- "(sphinx-build not found)"
- VERBATIM)
-
--ENDIF(PYTHON_SPHINX)
-+ENDIF(PYTHON_SPHINX AND ENABLE_DOC)
-
- ADD_DEPENDENCIES(doc_python vigranumpy)
- ADD_DEPENDENCIES(doc_python doc_cpp)
diff --git a/media-libs/vigra/files/1.7.1-png-1.5.patch b/media-libs/vigra/files/1.7.1-png-1.5.patch
deleted file mode 100644
index 3fe6448b9ad9..000000000000
--- a/media-libs/vigra/files/1.7.1-png-1.5.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-
-# HG changeset patch
-# User Ullrich Koethe <ullrich.koethe@iwr.uni-heidelberg.de>
-# Date 1299851742 -3600
-# Node ID c3a55cf81b34ae5e71e14b1dc90ece7e646a02dd
-# Parent 90494fd71974b95c61181a47580f4d1f02642723
-update for libpng 1.5 (fix by Mark Brand, mingw-cross-env)
-
-diff -r 90494fd71974 -r c3a55cf81b34 src/impex/png.cxx
---- a/src/impex/png.cxx Thu Mar 10 18:47:50 2011 +0100
-+++ b/src/impex/png.cxx Fri Mar 11 14:55:42 2011 +0100
-@@ -320,7 +320,11 @@
- #if (PNG_LIBPNG_VER > 10008) && defined(PNG_READ_iCCP_SUPPORTED)
- char * dummyName;
- int dummyCompType;
-+#if (PNG_LIBPNG_VER < 10500)
- char * profilePtr;
-+#else
-+ png_byte * profilePtr;
-+#endif
- png_uint_32 profileLen;
- if (png_get_valid( png, info, PNG_INFO_iCCP )) {
- png_get_iCCP(png, info, &dummyName, &dummyCompType, &profilePtr, &profileLen) ;
-@@ -593,7 +597,11 @@
- // set icc profile
- if (iccProfile.size() > 0) {
- png_set_iCCP(png, info, (png_charp)("icc"), 0,
-+#if (PNG_LIBPNG_VER < 10500)
- (png_charp)iccProfile.begin(), (png_uint_32)iccProfile.size());
-+#else
-+ (png_byte*)iccProfile.begin(), (png_uint_32)iccProfile.size());
-+#endif
- }
- #endif
-
-