summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/audtty/files/audtty-0.1.8-cc-and-destdir.patch')
-rw-r--r--media-sound/audtty/files/audtty-0.1.8-cc-and-destdir.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/audtty/files/audtty-0.1.8-cc-and-destdir.patch b/media-sound/audtty/files/audtty-0.1.8-cc-and-destdir.patch
new file mode 100644
index 000000000000..255952c61e55
--- /dev/null
+++ b/media-sound/audtty/files/audtty-0.1.8-cc-and-destdir.patch
@@ -0,0 +1,30 @@
+diff -ur audtty-0.1.8.orig/Makefile.in audtty-0.1.8/Makefile.in
+--- audtty-0.1.8.orig/Makefile.in 2008-02-06 04:16:47.000000000 +0200
++++ audtty-0.1.8/Makefile.in 2008-04-11 14:24:32.000000000 +0300
+@@ -20,18 +20,18 @@
+ all: audtty
+
+ audtty: ${BINS}
+- gcc -Wall -lncurses -laudclient ${LDFLAGS} -o audtty $(BINS)
++ $(CC) -Wall -lncurses -laudclient ${LDFLAGS} -o audtty $(BINS)
+
+ .c.o:
+- gcc -Wall ${AUDACIOUS_CFLAGS} ${CFLAGS} -o $@ -c $<
++ $(CC) -Wall ${AUDACIOUS_CFLAGS} ${CFLAGS} -o $@ -c $<
+
+ install: audtty
+- mkdir -p ${bindir}
+- install -m 0755 audtty ${bindir}/audtty
+- mkdir -p ${mandir}
+- install -m 0644 audtty.1 ${mandir}/audtty.1
+- mkdir -p ${sysconfdir}
+- install -m 0644 audtty.conf ${sysconfdir}/audtty.conf
++ mkdir -p $(DESTDIR)${bindir}
++ install -m 0755 audtty $(DESTDIR)${bindir}/audtty
++ mkdir -p $(DESTDIR)${mandir}
++ install -m 0644 audtty.1 $(DESTDIR)${mandir}/audtty.1
++ mkdir -p $(DESTDIR)${sysconfdir}
++ install -m 0644 audtty.conf $(DESTDIR)${sysconfdir}/audtty.conf
+
+ uninstall:
+ rm ${bindir}/audtty || false