summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/darksnow/darksnow-0.5.ebuild')
-rw-r--r--media-sound/darksnow/darksnow-0.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/darksnow/darksnow-0.5.ebuild b/media-sound/darksnow/darksnow-0.5.ebuild
new file mode 100644
index 000000000000..9e38a8161b7b
--- /dev/null
+++ b/media-sound/darksnow/darksnow-0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/darksnow/darksnow-0.5.ebuild,v 1.1 2005/04/18 15:50:42 luckyduck Exp $
+
+
+DESCRIPTION="Streaming GTK2 Front-End based in Darkice Ice Streamer"
+HOMEPAGE="http://darksnow.radiolivre.org"
+SRC_URI="http://darksnow.radiolivre.org/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2
+ >=media-sound/darkice-0.14"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ #fix some makefile issues
+ sed -i -e "s:^PREFIX=.*:PREFIX=${D}/usr:" \
+ -e "s:^INTLPREFIX=.*:INTLPREFIX=${D}/usr:" \
+ -e "s:^CFLAGS=:CFLAGS=${CFLAGS} :" \
+ Makefile.in \
+ || die "could not patch Makefile"
+}
+
+src_install () {
+ dobin darksnow || die "could not install darksnow executable"
+ dodoc ${S}/documentation/{CHANGES,README.en}
+}