summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/shntool/shntool-3.0.10.ebuild')
-rw-r--r--media-sound/shntool/shntool-3.0.10.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/media-sound/shntool/shntool-3.0.10.ebuild b/media-sound/shntool/shntool-3.0.10.ebuild
new file mode 100644
index 000000000000..f4f1346b058c
--- /dev/null
+++ b/media-sound/shntool/shntool-3.0.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shntool/shntool-3.0.10.ebuild,v 1.1 2009/06/21 15:09:47 flameeyes Exp $
+
+DESCRIPTION="shntool is a multi-purpose WAVE data processing and reporting utility"
+HOMEPAGE="http://shnutils.freeshell.org/shntool/"
+SRC_URI="http://shnutils.freeshell.org/shntool/dist/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="flac shorten sox wavpack"
+
+RDEPEND="flac? ( media-libs/flac )
+ sox? ( media-sound/sox )
+ shorten? ( media-sound/shorten )
+ wavpack? ( media-sound/wavpack )"
+DEPEND="${RDEPEND}"
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS README ChangeLog AUTHORS doc/* || die
+}