summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/x264-svn-encoder/files/x264-svn-encoder-nolib.patch')
-rw-r--r--media-video/x264-svn-encoder/files/x264-svn-encoder-nolib.patch69
1 files changed, 69 insertions, 0 deletions
diff --git a/media-video/x264-svn-encoder/files/x264-svn-encoder-nolib.patch b/media-video/x264-svn-encoder/files/x264-svn-encoder-nolib.patch
new file mode 100644
index 000000000000..20ae0cc2b40a
--- /dev/null
+++ b/media-video/x264-svn-encoder/files/x264-svn-encoder-nolib.patch
@@ -0,0 +1,69 @@
+Index: x264-svn/Makefile
+===================================================================
+--- x264-svn.orig/Makefile
++++ x264-svn/Makefile
+@@ -75,10 +75,10 @@ libx264.a: .depend $(OBJS) $(OBJASM)
+ $(SONAME): .depend $(OBJS) $(OBJASM)
+ $(CC) -shared -o $@ $(OBJS) $(OBJASM) -Wl,-soname,$(SONAME) $(LDFLAGS)
+
+-x264$(EXE): $(OBJCLI) libx264.a
+- $(CC) -o $@ $+ $(LDFLAGS)
++x264$(EXE): $(OBJCLI)
++ $(CC) -o $@ $+ $(LDFLAGS) `pkg-config --libs x264`
+
+-libx264gtk.a: muxers.o libx264.a
++libx264gtk.a: muxers.o
+ $(MAKE) -C gtk
+
+ checkasm: tools/checkasm.o libx264.a
+@@ -142,16 +142,10 @@ distclean: clean
+ rm -rf test/
+ $(MAKE) -C gtk distclean
+
+-install: x264 $(SONAME)
++install: x264
+ install -d $(DESTDIR)$(bindir) $(DESTDIR)$(includedir)
+ install -d $(DESTDIR)$(libdir) $(DESTDIR)$(libdir)/pkgconfig
+- install -m 644 x264.h $(DESTDIR)$(includedir)
+- install -m 644 libx264.a $(DESTDIR)$(libdir)
+- install -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig
+ install x264 $(DESTDIR)$(bindir)
+- ranlib $(DESTDIR)$(libdir)/libx264.a
+- $(if $(SONAME), ln -sf $(SONAME) $(DESTDIR)$(libdir)/libx264.so)
+- $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(libdir))
+
+ install-gtk: libx264gtk.a
+ $(MAKE) -C gtk install
+Index: x264-svn/configure
+===================================================================
+--- x264-svn.orig/configure
++++ x264-svn/configure
+@@ -423,7 +423,6 @@ cp config.mak gtk/config.mak
+ if [ "$shared" = "yes" ]; then
+ API=$(grep '#define X264_BUILD' < x264.h | cut -f 3 -d ' ')
+ echo "SONAME=libx264.so.$API" >> config.mak
+- echo 'default: $(SONAME)' >> config.mak
+ if [ "$gtk" = "yes" ]; then
+ echo "SONAMEGTK=libx264gtk.so.$API" >> gtk/config.mak
+ fi
+Index: x264-svn/gtk/Makefile
+===================================================================
+--- x264-svn.orig/gtk/Makefile
++++ x264-svn/gtk/Makefile
+@@ -46,14 +46,14 @@ SOURCES_ALL = $(OBJECTS_ALL:%.o=%.c)
+
+ X264GTK_PC = x264gtk.pc
+
+-EXTERNAL_DEPS= ../muxers.o ../matroska.o ../libx264.a
++EXTERNAL_DEPS= ../muxers.o ../matroska.o
+
+
+ all: $(ENCODE_BIN) $(TEST_BIN) $(MO_FILES) $(X264GTK_PC)
+
+ # Already provides iconv/intl
+ CPPFLAGS = -g `pkg-config --cflags gtk+-2.0 gthread-2.0` -I.. -DX264_DATA_DIR=\"${datadir}\"
+-LDFLAGS += `pkg-config --libs gtk+-2.0 gthread-2.0` ../libx264.a
++LDFLAGS += `pkg-config --libs gtk+-2.0 gthread-2.0 x264`
+
+
+ # gettext rules