summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/bmon/bmon-2.1.0-r2.ebuild')
-rw-r--r--net-analyzer/bmon/bmon-2.1.0-r2.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/net-analyzer/bmon/bmon-2.1.0-r2.ebuild b/net-analyzer/bmon/bmon-2.1.0-r2.ebuild
index 36a8fcbf6019..59b5b2d6583b 100644
--- a/net-analyzer/bmon/bmon-2.1.0-r2.ebuild
+++ b/net-analyzer/bmon/bmon-2.1.0-r2.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/bmon-2.1.0-r2.ebuild,v 1.8 2006/08/19 12:56:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/bmon-2.1.0-r2.ebuild,v 1.9 2007/02/01 21:29:46 jokey Exp $
inherit eutils toolchain-funcs
DESCRIPTION="interface bandwidth monitor"
HOMEPAGE="http://people.suug.ch/~tgr/bmon/"
SRC_URI="http://people.suug.ch/~tgr/bmon/files/${P}.tar.gz"
+
LICENSE="Artistic"
SLOT="0"
KEYWORDS="amd64 hppa ~ppc x86"
@@ -19,23 +20,21 @@ DEPEND=">=sys-libs/ncurses-5.3-r2
src_unpack() {
unpack ${A}
+ cd "${S}"
# gcc4 fix, bug 105343
- epatch ${FILESDIR}/${P}-gcc4.diff
-
+ epatch "${FILESDIR}"/${P}-gcc4.diff
# Don't strip, bug #144370
- cd ${S}
- epatch ${FILESDIR}/${PN}-nostrip.patch
+ epatch "${FILESDIR}"/${P}-nostrip.patch
}
src_compile() {
econf \
$(use_enable dbi) \
- $(use_enable rrdtool rrd) || die
- emake CPPFLAGS="${CXXFLAGS} -I${WORKDIR}/libnl-${NLVER}/include" || die
+ $(use_enable rrdtool rrd) || die "econf failed"
+ emake CPPFLAGS="${CXXFLAGS} -I${WORKDIR}/libnl-${NLVER}/include" || die "emake failed"
}
-
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc ChangeLog
}