summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/hping/hping-2.0.0_rc2-r1.ebuild')
-rw-r--r--net-analyzer/hping/hping-2.0.0_rc2-r1.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/net-analyzer/hping/hping-2.0.0_rc2-r1.ebuild b/net-analyzer/hping/hping-2.0.0_rc2-r1.ebuild
index 0f9f1ede275a..700335ba2394 100644
--- a/net-analyzer/hping/hping-2.0.0_rc2-r1.ebuild
+++ b/net-analyzer/hping/hping-2.0.0_rc2-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/hping-2.0.0_rc2-r1.ebuild,v 1.1 2003/12/03 21:30:28 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/hping-2.0.0_rc2-r1.ebuild,v 1.1.1.1 2005/11/30 10:12:43 chriswhite Exp $
+
+inherit eutils
S=${WORKDIR}/hping2-rc2
DESCRIPTION="A ping-like TCP/IP packet assembler/analyzer."
@@ -9,20 +11,21 @@ HOMEPAGE="http://www.hping.org"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc ~hppa ~ia64 ~amd64 ~alpha"
+KEYWORDS="x86 sparc hppa ia64 amd64 alpha ppc"
-DEPEND="net-libs/libpcap"
+DEPEND="virtual/libpcap"
+IUSE="debug"
src_compile() {
epatch ${FILESDIR}/wlan-header-fix.patch
./configure || die
- if [ `use debug` ]
+ if use debug
then
make CCOPT="${CFLAGS}" || die
else
- make CCOPT="${CFLAGS}" || die
+ make CCOPT="${CFLAGS}" DEBUG="" || die
fi
}