summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nmap/nmap-3.81.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-3.81.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/net-analyzer/nmap/nmap-3.81.ebuild b/net-analyzer/nmap/nmap-3.81.ebuild
index a2c27a848e87..5dc66cbdd115 100644
--- a/net-analyzer/nmap/nmap-3.81.ebuild
+++ b/net-analyzer/nmap/nmap-3.81.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-3.81.ebuild,v 1.1 2005/02/08 17:08:02 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-3.81.ebuild,v 1.1.1.1 2005/11/30 10:12:22 chriswhite Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="A utility for network exploration or security auditing"
HOMEPAGE="http://www.insecure.org/nmap/"
@@ -10,23 +10,24 @@ SRC_URI="http://www.insecure.org/nmap/dist/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~amd64 ~ppc64 ~s390 ~ia64 ~ppc-macos"
-IUSE="gtk gnome ipv6"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc-macos ppc64 s390 sh sparc x86"
+IUSE="gtk ssl"
DEPEND="virtual/libc
dev-libs/libpcre
- gtk? ( =x11-libs/gtk+-1.2* )"
+ gtk? ( =x11-libs/gtk+-1.2* )
+ ssl? ( dev-libs/openssl )"
src_compile() {
- econf `use_with gtk nmapfe` \
- `use_enable ipv6` || die
+ use ppc-macos && filter-flags -fstrict-aliasing -O2
+ econf \
+ $(use_with gtk nmapfe) \
+ $(use_with ssl openssl) || die
emake -j1 || die
}
src_install() {
einstall -j1 nmapdatadir=${D}/usr/share/nmap install || die
- use gnome || rm -rf ${D}/usr/share/gnome/
-
dodoc CHANGELOG HACKING INSTALL docs/README docs/*.txt
dohtml docs/*.html
}