summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/portsentry/portsentry-1.1-r7.ebuild')
-rw-r--r--net-analyzer/portsentry/portsentry-1.1-r7.ebuild34
1 files changed, 19 insertions, 15 deletions
diff --git a/net-analyzer/portsentry/portsentry-1.1-r7.ebuild b/net-analyzer/portsentry/portsentry-1.1-r7.ebuild
index 6ffd3a017fd8..a402d6ba3b41 100644
--- a/net-analyzer/portsentry/portsentry-1.1-r7.ebuild
+++ b/net-analyzer/portsentry/portsentry-1.1-r7.ebuild
@@ -1,34 +1,38 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portsentry/portsentry-1.1-r7.ebuild,v 1.1 2002/09/27 17:53:16 g2boojum Exp $
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portsentry/portsentry-1.1-r7.ebuild,v 1.1.1.1 2005/11/30 10:12:14 chriswhite Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Automated port scan detector and response tool"
-HOMEPAGE="http://www.psionic.com/abacus/portsentry/"
-SRC_URI="http://www.psionic.com/tools/${P}.tar.gz"
+# Seems like CISCO took the site down?
+HOMEPAGE="http://sourceforge.net/projects/sentrytools/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc sparc64"
+KEYWORDS="x86 ppc sparc"
+IUSE=""
-DEPEND="sys-apps/supersed"
+DEPEND=">=sys-apps/sed-4"
src_unpack() {
unpack ${A} ; cd ${S}
# Setting the portsentry.conf file location
- ssed -i -e 's:/usr/local/psionic/portsentry/portsentry.conf:/etc/portsentry/portsentry.conf:' \
- portsentry_config.h
+ sed -i \
+ -e 's:/usr/local/psionic/portsentry/portsentry.conf:/etc/portsentry/portsentry.conf:' \
+ portsentry_config.h || die "sed portsentry_config.h failed"
# presetting the other file locations in portsentry.conf
- ssed -i -e 's:\(^IGNORE_FILE\).*:\1="/etc/portsentry/portsentry.ignore":g' \
+ sed -i \
+ -e 's:\(^IGNORE_FILE\).*:\1="/etc/portsentry/portsentry.ignore":g' \
-e 's:^\(HISTORY_FILE\).*:\1="/etc/portsentry/portsentry.history":g' \
-e 's:^\(BLOCKED_FILE\).*:\1="/etc/portsentry/portsentry.blocked":g' \
- portsentry.conf
+ portsentry.conf || die "sed portsentry.conf failed"
- ssed -i "s:^set SENTRYDIR.*:set SENTRYDIR=/etc/portsentry:g" \
- ignore.csh
+ sed -i \
+ -e "s:^set SENTRYDIR.*:set SENTRYDIR=/etc/portsentry:g" \
+ ignore.csh || die "sed ignore.csh failed"
}
src_compile() {
@@ -36,7 +40,7 @@ src_compile() {
make CFLAGS="${CFLAGS}" linux || die
}
-src_install () {
+src_install() {
dobin portsentry ignore.csh
dodoc README* CHANGES LICENSE CREDITS