summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild')
-rw-r--r--net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild b/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild
index f6a776f930f1..f82f51f48b7e 100644
--- a/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild
+++ b/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild
@@ -1,28 +1,37 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild,v 1.1 2003/12/17 09:57:52 mboman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild,v 1.1.1.1 2005/11/30 10:12:29 chriswhite Exp $
+
+inherit eutils
# Note: this ebuild is not of the best quality as it is entirely
-# static. However I belive that I will get away with it as the software
+# static. However I believe that I will get away with it as the software
# itself haven't been updated since 1996.
DESCRIPTION="Tcpslice is a program for extracting portions of packet-trace files generated using tcpdump's -w flag. It can also be used to glue together pcap dump files."
HOMEPAGE="http://www.tcpdump.org/"
-SRC_URI="ftp://ftp.debian.org/debian/pool/main/t/tcpslice/tcpslice_1.1a3.orig.tar.gz
- ftp://ftp.debian.org/debian/pool/main/t/tcpslice/tcpslice_1.1a3-1.1.diff.gz"
+SRC_URI="mirror://debian/pool/main/t/tcpslice/tcpslice_1.1a3.orig.tar.gz
+ mirror://debian/pool/main/t/tcpslice/tcpslice_1.1a3-1.1.diff.gz"
+RESTRICT="nomirror"
+
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~ppc x86"
IUSE=""
-DEPEND="virtual/glibc
- >=net-libs/libpcap-0.6.2-r1"
-RDEPEND="${DEPEND}"
+RDEPEND="virtual/libc
+ virtual/libpcap"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
S=${WORKDIR}/tcpslice-1.1a3
src_unpack() {
unpack ${A}
epatch ${DISTDIR}/tcpslice_1.1a3-1.1.diff.gz
+ cd ${S}
+ sed -i -e 's:net/bpf.h:pcap-bpf.h:g' tcpslice.c || die
}
src_compile() {