summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/thc-ipv6/files')
-rw-r--r--net-analyzer/thc-ipv6/files/thc-ipv6-2.0-Makefile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-analyzer/thc-ipv6/files/thc-ipv6-2.0-Makefile.patch b/net-analyzer/thc-ipv6/files/thc-ipv6-2.0-Makefile.patch
new file mode 100644
index 000000000000..0d46c2773b88
--- /dev/null
+++ b/net-analyzer/thc-ipv6/files/thc-ipv6-2.0-Makefile.patch
@@ -0,0 +1,22 @@
+--- thc-ipv6-2.0/Makefile
++++ thc-ipv6-2.0/Makefile
+@@ -2,8 +2,9 @@
+ #CFLAGS?=-Wall -ggdb
+ CFLAGS?=-O2
+ LDFLAGS+=-lpcap -lssl -lcrypto
+-PROGRAMS=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_solicitate6 fake_mld6 fake_mld26 fake_mldrouter6 flood_mldrouter6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 implementation6 implementation6d sendpees6 sendpeesmp6 randicmp6 fuzz_ip6 flood_mld6 flood_mld26 flood_router6 flood_router26 flood_advertise6 flood_solicitate6 trace6 exploit6 denial6 fake_dhcps6 flood_dhcpc6 fake_dns6d fragmentation6 kill_router6 fake_dnsupdate6 ndpexhaust6 detect_sniffer6 dump_router6 fake_router26 passive_discovery6 dnsrevenum6 inverse_lookup6 node_query6 address6 thcping6 covert_send6 covert_send6d
++PROGRAMS=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_solicitate6 fake_mld6 fake_mld26 fake_mldrouter6 flood_mldrouter6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 implementation6 implementation6d sendpees6 sendpeesmp6 randicmp6 fuzz_ip6 flood_mld6 flood_mld26 flood_router6 flood_router26 flood_advertise6 flood_solicitate6 trace6 exploit6 denial6 fake_dhcps6 flood_dhcpc6 fake_dns6d fragmentation6 kill_router6 fake_dnsupdate6 ndpexhaust6 detect_sniffer6 dump_router6 fake_router26 passive_discovery6 dnsrevenum6 inverse_lookup6 node_query6 address6 covert_send6 covert_send6d
+ LIBS=thc-ipv6-lib.o
++STRIP=strip
+
+ PREFIX=/usr/local
+ MANPREFIX=${PREFIX}/share/man
+@@ -20,7 +21,7 @@
+ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ strip: all
+- strip $(PROGRAMS) dnsdict6 thcping6
++ $(STRIP) $(PROGRAMS) dnsdict6 thcping6
+
+ install: all strip
+ install -m0755 -d ${DESTDIR}${PREFIX}/bin