summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/upnpscan/upnpscan-0.4.ebuild')
-rw-r--r--net-analyzer/upnpscan/upnpscan-0.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/upnpscan/upnpscan-0.4.ebuild b/net-analyzer/upnpscan/upnpscan-0.4.ebuild
new file mode 100644
index 000000000000..106cb12d37b6
--- /dev/null
+++ b/net-analyzer/upnpscan/upnpscan-0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/upnpscan/upnpscan-0.4.ebuild,v 1.1 2005/12/10 22:36:28 vanquirius Exp $
+
+DESCRIPTION="Scans the network for UPNP capable devices"
+HOMEPAGE="http://www.cqure.net/tools.jsp?id=23"
+SRC_URI="http://www.cqure.net/tools/${PN}-v${PV}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="static"
+
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ if use static ; then
+ econf || die
+ else
+ econf --enable-static=no || die
+ fi
+ emake || die
+}
+
+src_install() {
+ dobin "${S}"/src/upnpscan || die
+}