summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/hsfmodem/files/hsfmodem-7.68.00.12-gentoo.patch')
-rw-r--r--net-dialup/hsfmodem/files/hsfmodem-7.68.00.12-gentoo.patch81
1 files changed, 77 insertions, 4 deletions
diff --git a/net-dialup/hsfmodem/files/hsfmodem-7.68.00.12-gentoo.patch b/net-dialup/hsfmodem/files/hsfmodem-7.68.00.12-gentoo.patch
index 340e18bfa0b0..aafc0dcfc3a5 100644
--- a/net-dialup/hsfmodem/files/hsfmodem-7.68.00.12-gentoo.patch
+++ b/net-dialup/hsfmodem/files/hsfmodem-7.68.00.12-gentoo.patch
@@ -1,6 +1,6 @@
diff -ur hsfmodem-7.68.00.12x86_64full.orig/modules/Makefile hsfmodem-7.68.00.12x86_64full/modules/Makefile
---- hsfmodem-7.68.00.12x86_64full.orig/modules/Makefile 2008-07-16 15:24:00.000000000 +0000
-+++ hsfmodem-7.68.00.12x86_64full/modules/Makefile 2008-07-30 20:48:03.000000000 +0000
+--- hsfmodem-7.68.00.12x86_64full.orig/modules/Makefile 2008-08-01 21:22:36.000000000 +0000
++++ hsfmodem-7.68.00.12x86_64full/modules/Makefile 2008-08-01 21:22:08.000000000 +0000
@@ -145,7 +145,7 @@
ifeq ($(ON_BUILD_SYSTEM)-$(CONFIG_SND_HDA_INTEL),no-)
# On Ubuntu Gutsy (7.10), the HDA modules are not included in linux-image but in a seprarate package
@@ -11,8 +11,8 @@ diff -ur hsfmodem-7.68.00.12x86_64full.orig/modules/Makefile hsfmodem-7.68.00.12
else
diff -ur hsfmodem-7.68.00.12x86_64full.orig/scripts/cnxtconfig.in hsfmodem-7.68.00.12x86_64full/scripts/cnxtconfig.in
---- hsfmodem-7.68.00.12x86_64full.orig/scripts/cnxtconfig.in 2008-03-27 19:43:38.000000000 +0000
-+++ hsfmodem-7.68.00.12x86_64full/scripts/cnxtconfig.in 2008-07-30 20:48:03.000000000 +0000
+--- hsfmodem-7.68.00.12x86_64full.orig/scripts/cnxtconfig.in 2008-08-01 21:22:36.000000000 +0000
++++ hsfmodem-7.68.00.12x86_64full/scripts/cnxtconfig.in 2008-08-01 21:22:08.000000000 +0000
@@ -1973,9 +1973,9 @@
if [ -d /etc/udev/rules.d ]; then
rm -f /etc/udev/rules.d/00-@CNXTTARGET@.rules
@@ -25,3 +25,76 @@ diff -ur hsfmodem-7.68.00.12x86_64full.orig/scripts/cnxtconfig.in hsfmodem-7.68.
fi
fi
+diff -ur hsfmodem-7.68.00.12x86_64full.orig/scripts/rccnxt.in hsfmodem-7.68.00.12x86_64full/scripts/rccnxt.in
+--- hsfmodem-7.68.00.12x86_64full.orig/scripts/rccnxt.in 2008-08-01 21:22:36.000000000 +0000
++++ hsfmodem-7.68.00.12x86_64full/scripts/rccnxt.in 2008-08-01 21:23:20.000000000 +0000
+@@ -1,63 +1,12 @@
+-#
+-# chkconfig: 2345 09 91
+-# description: @CNXTDRVDSC@
+-#
+-### BEGIN INIT INFO
+-# Provides: @CNXTTARGET@
+-# Should-Start: hotplug coldplug
+-# Required-Start: $local_fs
+-# Required-Stop: $network
+-# Default-Start: 3 5
+-# Default-Stop: 0 1 2 6
+-# Description: Start @CNXTDRVDSC@
+-### END INIT INFO
+
+-if [ -e /etc/runlevels ]; then
+- begincmd="ebegin"
+- endcmd="eend"
+-else
+- begincmd="echo"
+- endcmd="/bin/true"
+-fi
+-
+-
+-start()
+-{
+- ${begincmd} "Starting @CNXTDRVDSC@"
++start() {
++ ebegin "Starting @CNXTDRVDSC@"
+ @CNXTSBINDIR@/@CNXTTARGET@config --rcstart
+- ${endcmd} 0
++ eend 0
+ }
+
+-stop()
+-{
+- ${begincmd} "Stopping @CNXTDRVDSC@"
++stop() {
++ ebegin "Stopping @CNXTDRVDSC@"
+ @CNXTSBINDIR@/@CNXTTARGET@config --rcstop
+- ${endcmd} 0
++ eend 0
+ }
+-
+-restart()
+-{
+- stop
+- start
+-}
+-
+-if [ ! -e /etc/runlevels ]; then
+- case "$1" in
+- start)
+- start
+- ;;
+- stop)
+- stop
+- ;;
+- restart|force-reload|reload)
+- restart
+- ;;
+- status)
+- exit 3
+- ;;
+- *)
+- echo "Usage: $0 {start|stop|status|try-restart|restart|force-reload|reload}"
+- exit 1
+- ;;
+- esac
+-fi