summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/dnsmasq/dnsmasq-2.59.ebuild')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.59.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.59.ebuild b/net-dns/dnsmasq/dnsmasq-2.59.ebuild
new file mode 100644
index 000000000000..b445a7a73556
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.59.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.59.ebuild,v 1.1 2011/11/09 01:32:08 chutzpah Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.lzma"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="conntrack dbus +dhcp idn ipv6 nls tftp"
+
+RDEPEND="dbus? ( sys-apps/dbus )
+ idn? ( net-dns/libidn )
+ conntrack? ( net-libs/libnetfilter_conntrack )
+ nls? (
+ sys-devel/gettext
+ net-dns/libidn
+ )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ || ( app-arch/xz-utils app-arch/lzma-utils )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+pkg_setup() {
+ enewgroup dnsmasq
+ enewuser dnsmasq -1 -1 /dev/null dnsmasq
+}
+
+src_prepare() {
+ # dnsmasq on FreeBSD wants the config file in a silly location, this fixes
+ epatch "${FILESDIR}/${PN}-2.47-fbsd-config.patch"
+}
+
+src_configure() {
+ COPTS=""
+ use conntrack && COPTS+=" -DHAVE_CONNTRACK"
+ use tftp || COPTS+=" -DNO_TFTP"
+ use dhcp || COPTS+=" -DNO_DHCP"
+ use ipv6 || COPTS+=" -DNO_IPV6"
+ use dbus && COPTS+=" -DHAVE_DBUS"
+ use idn && COPTS+=" -DHAVE_IDN"
+}
+
+src_compile() {
+ emake \
+ PREFIX=/usr \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ COPTS="${COPTS}" \
+ all$(use nls && echo "-i18n")
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR="${D}" \
+ install$(use nls && echo "-i18n")
+
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/dnsmasq-init-r1 dnsmasq
+ newconfd "${FILESDIR}"/dnsmasq.confd-r1 dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+
+ if use dbus ; then
+ insinto /etc/dbus-1/system.d
+ doins dbus/dnsmasq.conf
+ fi
+}