summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/ebtables/ebtables-2.0.6.ebuild')
-rw-r--r--net-firewall/ebtables/ebtables-2.0.6.ebuild32
1 files changed, 25 insertions, 7 deletions
diff --git a/net-firewall/ebtables/ebtables-2.0.6.ebuild b/net-firewall/ebtables/ebtables-2.0.6.ebuild
index 9140d24a5f4e..40bb964e703a 100644
--- a/net-firewall/ebtables/ebtables-2.0.6.ebuild
+++ b/net-firewall/ebtables/ebtables-2.0.6.ebuild
@@ -1,17 +1,35 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ebtables/ebtables-2.0.6.ebuild,v 1.1 2004/02/28 09:25:14 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ebtables/ebtables-2.0.6.ebuild,v 1.1.1.1 2005/11/30 10:11:18 chriswhite Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}-v${PV}"
DESCRIPTION="Utility that enables basic Ethernet frame filtering on a Linux bridge, MAC NAT and brouting."
-SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
-HOMEPAGE=""
-KEYWORDS="~x86"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://ebtables.sourceforge.net/"
+KEYWORDS="x86 ~ppc ~amd64"
+IUSE=""
LICENSE="GPL-2"
SLOT="0"
-S=${WORKDIR}/${PN}-v${PV}/
+S="${WORKDIR}/${MY_P}"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # fix "label at end of compound statement" error that
+ # prevents ebtables from being compilable with >=gcc-3.4
+ epatch ${FILESDIR}/ebtables-2.0.6-gcc34.patch
+}
src_install() {
dodir /sbin/