summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild')
-rw-r--r--net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild42
1 files changed, 20 insertions, 22 deletions
diff --git a/net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild b/net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild
index 4ed7b9e669de..7ffaa62f4e87 100644
--- a/net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild
+++ b/net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild,v 1.1 2004/01/23 11:44:21 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/fwbuilder/fwbuilder-1.1.2.ebuild,v 1.1.1.1 2005/11/30 10:11:21 chriswhite Exp $
+
+inherit flag-o-matic eutils
DESCRIPTION="A firewall GUI"
-SRC_URI="mirror://sourceforge/fwbuilder/${P}.tar.gz"
HOMEPAGE="http://www.fwbuilder.org/"
-RESTRICT="nomirror"
-S=${WORKDIR}/${P}
+SRC_URI="mirror://sourceforge/fwbuilder/${P}.tar.gz"
-KEYWORDS="~x86 ~sparc ~amd64"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 sparc amd64 ~ppc"
IUSE="static nls"
DEPEND="sys-devel/autoconf
@@ -20,32 +20,31 @@ DEPEND="sys-devel/autoconf
=dev-libs/libsigc++-1.0*
nls? ( >=sys-devel/gettext-0.11 )
~net-libs/libfwbuilder-1.0.2"
-RDEPEND="$DEPEND"
-# Added by Jason Wever <weeve@gentoo.org>
-# Fix for bug #30256.
-if [ "${ARCH}" = "sparc" ]; then
- inherit flag-o-matic
- replace-flags "-O3" "-O2"
-fi
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ epatch ${FILESDIR}/${P}-nls_fix.patch
+}
src_compile() {
+ use sparc && replace-flags -O3 -O2
local myconf
- myconf="--with-gnu-ld"
- use static && myconf="${myconf} --enable-shared=no --enable-static=yes"
- use nls || myconf="${myconf} --disable-nls"
+ use static && myconf="${myconf} --enable-shared=no --enable-static=yes"
+ use nls || myconf="${myconf} --disable-nls"
./autogen.sh \
--prefix=/usr \
- --host=${CHOST} || die "./configure failed"
+ --host=${CHOST} \
+ ${myconf} \
+ || die "./configure failed"
sed -i -e "s:#define HAVE_XMLSAVEFORMATFILE 1://:" config.h
- if [ "`use static`" ]
- then
+ if use static ; then
emake LDFLAGS="-static" || die "emake LDFLAGS failed"
else
- emake || die "emake failed"
+ make -j1 || die "emake failed"
fi
}
@@ -54,7 +53,6 @@ src_install() {
}
pkg_postinst() {
- einfo "You may have to install iproute on the machine that"
+ einfo "You need to emerge iproute2 on the machine that"
einfo "will run the firewall script."
}
-