summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/telepathy-idle/telepathy-idle-0.1.10.ebuild')
-rw-r--r--net-irc/telepathy-idle/telepathy-idle-0.1.10.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-irc/telepathy-idle/telepathy-idle-0.1.10.ebuild b/net-irc/telepathy-idle/telepathy-idle-0.1.10.ebuild
new file mode 100644
index 000000000000..56e1c5cca5ba
--- /dev/null
+++ b/net-irc/telepathy-idle/telepathy-idle-0.1.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/telepathy-idle/telepathy-idle-0.1.10.ebuild,v 1.1 2011/06/03 15:33:06 pacho Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Full-featured IRC connection manager for Telepathy."
+HOMEPAGE="http://telepathy.freedesktop.org/wiki/Components"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="dev-libs/dbus-glib
+ >=dev-libs/glib-2.8.6:2
+ >=dev-libs/openssl-0.9.7
+ >=net-libs/telepathy-glib-0.13.10
+ sys-apps/dbus"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? ( dev-python/twisted-words )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS || die
+}