summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mswatch')
-rw-r--r--net-mail/mswatch/ChangeLog8
-rw-r--r--net-mail/mswatch/files/mswatch-1.2.0-gcc47.patch26
-rw-r--r--net-mail/mswatch/mswatch-1.2.0.ebuild5
3 files changed, 35 insertions, 4 deletions
diff --git a/net-mail/mswatch/ChangeLog b/net-mail/mswatch/ChangeLog
index 91d0307156f9..57cb94ad84a0 100644
--- a/net-mail/mswatch/ChangeLog
+++ b/net-mail/mswatch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/mswatch
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mswatch/ChangeLog,v 1.4 2012/05/03 04:18:37 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mswatch/ChangeLog,v 1.5 2013/03/03 05:46:18 dirtyepic Exp $
+
+ 03 Mar 2013; Ryan Hill <dirtyepic@gentoo.org> mswatch-1.2.0.ebuild,
+ +files/mswatch-1.2.0-gcc47.patch:
+ Fix build with GCC 4.7 (bug #424673).
03 May 2012; Jeff Horelick <jdhore@gentoo.org> mswatch-1.2.0.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/net-mail/mswatch/files/mswatch-1.2.0-gcc47.patch b/net-mail/mswatch/files/mswatch-1.2.0-gcc47.patch
new file mode 100644
index 000000000000..c11052164c66
--- /dev/null
+++ b/net-mail/mswatch/files/mswatch-1.2.0-gcc47.patch
@@ -0,0 +1,26 @@
+ https://bugs.gentoo.org/424673
+
+ src/lib/util.cc | 1 +
+ src/watch_maildirs/inotify/state.cc | 1 +
+ 2 files changed, 2 insertions(+)
+
+--- a/src/lib/util.cc
++++ b/src/lib/util.cc
+@@ -6,6 +6,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <time.h>
++#include <unistd.h>
+
+ #include <sstream>
+ #include <string>
+--- a/src/watch_maildirs/inotify/state.cc
++++ b/src/watch_maildirs/inotify/state.cc
+@@ -1,6 +1,7 @@
+ #include <assert.h>
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <unistd.h>
+
+ #include "lib/util.h"
+ #include "state.h"
diff --git a/net-mail/mswatch/mswatch-1.2.0.ebuild b/net-mail/mswatch/mswatch-1.2.0.ebuild
index 26aac1a974ae..3597856a87c3 100644
--- a/net-mail/mswatch/mswatch-1.2.0.ebuild
+++ b/net-mail/mswatch/mswatch-1.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mswatch/mswatch-1.2.0.ebuild,v 1.4 2012/05/03 04:18:37 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mswatch/mswatch-1.2.0.ebuild,v 1.5 2013/03/03 05:46:18 dirtyepic Exp $
EAPI="4"
@@ -23,6 +23,7 @@ CONFIG_CHECK="~INOTIFY_USER"
ERROR_INOTIFY_USER="${P} requires in-kernel inotify support."
DOCS=( AUTHORS NEWS README THANKS TODO )
+PATCHES=( "${FILESDIR}"/${P}-gcc47.patch )
src_configure() {
local myeconfargs=(