summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/switzerland/switzerland-0.0.5.ebuild')
-rw-r--r--net-misc/switzerland/switzerland-0.0.5.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/net-misc/switzerland/switzerland-0.0.5.ebuild b/net-misc/switzerland/switzerland-0.0.5.ebuild
index 794e5599cfbd..ef2a431ee34f 100644
--- a/net-misc/switzerland/switzerland-0.0.5.ebuild
+++ b/net-misc/switzerland/switzerland-0.0.5.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/switzerland/switzerland-0.0.5.ebuild,v 1.1 2008/08/03 12:45:01 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/switzerland/switzerland-0.0.5.ebuild,v 1.2 2011/04/05 20:20:11 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
inherit distutils toolchain-funcs
@@ -16,10 +19,12 @@ IUSE=""
DEPEND="net-libs/libpcap"
RDEPEND=${DEPEND}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+src_prepare() {
cp "${FILESDIR}"/Makefile switzerland/client
sed -i \