summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/leechcraft-bittorrent/leechcraft-bittorrent-0.5.80.ebuild')
-rw-r--r--net-p2p/leechcraft-bittorrent/leechcraft-bittorrent-0.5.80.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-p2p/leechcraft-bittorrent/leechcraft-bittorrent-0.5.80.ebuild b/net-p2p/leechcraft-bittorrent/leechcraft-bittorrent-0.5.80.ebuild
new file mode 100644
index 000000000000..ddb3af92caa5
--- /dev/null
+++ b/net-p2p/leechcraft-bittorrent/leechcraft-bittorrent-0.5.80.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-bittorrent/leechcraft-bittorrent-0.5.80.ebuild,v 1.1 2012/08/13 14:13:15 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Full-featured BitTorrent client plugin for LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug geoip"
+
+DEPEND="~net-misc/leechcraft-core-${PV}
+ net-libs/rb_libtorrent"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-task-show
+ geoip? ( dev-libs/geoip )"
+
+src_configure(){
+ local mycmakeargs="
+ $(cmake-utils_use_enable geoip BITTORRENT_GEOIP)
+ "
+ cmake-utils_src_configure
+}