summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/gnome-bluetooth/gnome-bluetooth-2.32.0.ebuild')
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-2.32.0.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-2.32.0.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-2.32.0.ebuild
new file mode 100644
index 000000000000..53fecb6d3390
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-2.32.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/gnome-bluetooth-2.32.0.ebuild,v 1.1 2010/10/21 22:03:38 eva Exp $
+
+EAPI="3"
+
+inherit eutils gnome2
+
+DESCRIPTION="Fork of bluez-gnome focused on integration with GNOME"
+HOMEPAGE="http://live.gnome.org/GnomeBluetooth"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc +introspection nautilus"
+
+COMMON_DEPEND=">=dev-libs/glib-2.25.7:2
+ >=x11-libs/gtk+-2.19.1:2
+ >=x11-libs/libnotify-0.4.3
+ >=dev-libs/dbus-glib-0.74
+ dev-libs/libunique
+ nautilus? ( >=gnome-extra/nautilus-sendto-2.31.7 )"
+RDEPEND="${COMMON_DEPEND}
+ >=net-wireless/bluez-4.34
+ app-mobilephone/obexd"
+DEPEND="${COMMON_DEPEND}
+ !!net-wireless/bluez-gnome
+ app-text/gnome-doc-utils
+ app-text/scrollkeeper
+ dev-libs/libxml2
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-proto/xproto
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+# eautoreconf needs:
+# gnome-base/gnome-common
+# dev-util/gtk-doc-am
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable introspection)
+ $(use_enable nautilus nautilus-sendto)
+ --disable-moblin
+ --disable-desktop-update
+ --disable-icon-update"
+ DOCS="AUTHORS README NEWS ChangeLog"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${ED}"/usr/$(get_libdir)/${PN}/plugins -name "*.la" -delete \
+ || die "la file removal failed (1)"
+ find "${ED}"/usr/$(get_libdir)/nautilus-sendto/plugins -name "*.la" -delete \
+ || die "la file removal failed (1)"
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ preserve_old_lib /usr/$(get_libdir)/libgnome-bluetooth.so.7
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ preserve_old_lib_notify /usr/$(get_libdir)/libgnome-bluetooth.so.7
+}