summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/zd1211/zd1211-20050315.ebuild')
-rw-r--r--net-wireless/zd1211/zd1211-20050315.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-wireless/zd1211/zd1211-20050315.ebuild b/net-wireless/zd1211/zd1211-20050315.ebuild
new file mode 100644
index 000000000000..461588ee80ab
--- /dev/null
+++ b/net-wireless/zd1211/zd1211-20050315.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/zd1211/zd1211-20050315.ebuild,v 1.1 2005/04/22 19:56:50 genstef Exp $
+
+inherit linux-mod
+
+DESCRIPTION="Driver for the zd1211 wireless chipset"
+HOMEPAGE="http://zd1211.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zd1211/sf_${PN}_${PV}_src.tar.gz"
+S=${WORKDIR}/${PN}
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="net-wireless/wireless-tools"
+MODULE_NAMES="zd1211(net:)"
+BUILD_TARGETS="all"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KSRC=${KV_DIR} KDIR=${KV_DIR}"
+}
+
+src_compile() {
+ linux-mod_src_compile
+ emake -C tools
+}
+
+src_install() {
+ linux-mod_src_install
+ dobin tools/apdbg
+ dodoc README CHANGES
+}