summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/mod_mp3')
-rw-r--r--net-www/mod_mp3/ChangeLog9
-rw-r--r--net-www/mod_mp3/files/digest-mod_mp3-0.351
-rw-r--r--net-www/mod_mp3/files/mod_mp3.conf16
-rw-r--r--net-www/mod_mp3/mod_mp3-0.35.ebuild46
4 files changed, 72 insertions, 0 deletions
diff --git a/net-www/mod_mp3/ChangeLog b/net-www/mod_mp3/ChangeLog
new file mode 100644
index 000000000000..5bbdbf9ef6c6
--- /dev/null
+++ b/net-www/mod_mp3/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-www/mod_mp3
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/ChangeLog,v 1.1 2002/04/09 23:57:52 woodchip Exp $
+
+*mod_mp3-0.35 (9 Apr 2002)
+
+ 9 Apr 2002; Donny Davies <woodchip@gentoo.org> :
+
+ New package to go along with the rewritten apache ebuild.
diff --git a/net-www/mod_mp3/files/digest-mod_mp3-0.35 b/net-www/mod_mp3/files/digest-mod_mp3-0.35
new file mode 100644
index 000000000000..5754bce8c732
--- /dev/null
+++ b/net-www/mod_mp3/files/digest-mod_mp3-0.35
@@ -0,0 +1 @@
+MD5 cad75f267767127b829ac73a809a2954 mod_mp3-0.35.tar.gz 43694
diff --git a/net-www/mod_mp3/files/mod_mp3.conf b/net-www/mod_mp3/files/mod_mp3.conf
new file mode 100644
index 000000000000..6fad951f6017
--- /dev/null
+++ b/net-www/mod_mp3/files/mod_mp3.conf
@@ -0,0 +1,16 @@
+<IfModule mod_mp3.c>
+
+#Listen 80
+Listen 8000
+
+<VirtualHost _default_:8000>
+
+MP3Engine On
+MP3CastName "mod_mp3"
+MP3Genre "Sounds of Open Source"
+MP3 /export/mp3
+Timeout 1200
+
+</VirtualHost>
+
+</IfModule>
diff --git a/net-www/mod_mp3/mod_mp3-0.35.ebuild b/net-www/mod_mp3/mod_mp3-0.35.ebuild
new file mode 100644
index 000000000000..fdd74fce4549
--- /dev/null
+++ b/net-www/mod_mp3/mod_mp3-0.35.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/mod_mp3-0.35.ebuild,v 1.1 2002/04/09 23:57:52 woodchip Exp $
+
+DESCRIPTION="Module for turning Apache into an MP3 or Ogg streaming server"
+HOMEPAGE="http://media.tangent.org/"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://software.tangent.org/download/${P}.tar.gz"
+
+DEPEND="virtual/glibc >=net-www/apache-1.3.24 sys-devel/perl"
+
+src_compile() {
+ ./configure || die
+ make clean
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe src/mod_mp3.so
+
+ dodoc CONTRIBUTORS MANIFEST TODO ChangeLog LICENSE README VERSION
+ dodoc support/{faq.pod,mp3_with_mysql.conf,mysql_schema,pgsql_schema}
+ dohtml faq.html
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_mp3.conf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Execute ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/mod_mp3.so mod_mp3.c mp3_module \
+ define=MP3 addconf=conf/addon-modules/mod_mp3.conf
+ :;
+}