summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/mod_random/mod_random-2.0.ebuild')
-rw-r--r--net-www/mod_random/mod_random-2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-www/mod_random/mod_random-2.0.ebuild b/net-www/mod_random/mod_random-2.0.ebuild
new file mode 100644
index 000000000000..cc2440337e02
--- /dev/null
+++ b/net-www/mod_random/mod_random-2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_random/mod_random-2.0.ebuild,v 1.1 2002/11/28 20:47:14 woodchip Exp $
+
+inherit eutils
+
+DESCRIPTION="An Apache2 DSO providing custom randomized responses"
+HOMEPAGE="http://software.tangent.org/"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://software.tangent.org/download/${P}.tar.gz"
+DEPEND="=net-www/apache-2*"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} || die; cd ${S} || die
+ epatch ${FILESDIR}/mod_random-register.patch
+}
+
+src_compile() {
+ apxs2 -c ${PN}.c || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/${PN}.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/17_mod_random.conf
+ dodoc ${FILESDIR}/17_mod_random.conf
+ dodoc ChangeLog INSTALL LICENSE README VERSION
+ dohtml *.html
+}