summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/mira/mira-3.0.1.ebuild')
-rw-r--r--sci-biology/mira/mira-3.0.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-biology/mira/mira-3.0.1.ebuild b/sci-biology/mira/mira-3.0.1.ebuild
new file mode 100644
index 000000000000..ab4263fb42c9
--- /dev/null
+++ b/sci-biology/mira/mira-3.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/mira-3.0.1.ebuild,v 1.1 2010/03/06 23:05:28 weaver Exp $
+
+EAPI="2"
+
+MIRA_3RDPARTY_PV="06-03-2010"
+
+inherit base autotools
+
+DESCRIPTION="Whole Genome Shotgun and EST Sequence Assembler for Sanger, 454 and Solexa / Illumina"
+HOMEPAGE="http://www.chevreux.org/projects_mira.html"
+SRC_URI="mirror://sourceforge/mira-assembler/${P}.tar.bz2
+ mirror://sourceforge/mira-assembler/mira_3rdparty_${MIRA_3RDPARTY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND=">=dev-libs/boost-1.35.0"
+DEPEND="${CDEPEND}
+ dev-libs/expat
+ doc? ( >=app-text/texlive-core-2009 )"
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ find -name 'configure*' -or -name 'Makefile*' | xargs sed -i 's/flex++/flex -+/' || die
+ epatch "${FILESDIR}"/${PN}-3.0.0-asneeded.patch
+ AT_M4DIR="config/m4" eautoreconf
+}
+
+src_compile() {
+ base_src_compile
+ if use doc; then emake -C doc clean docs || die; fi
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS GETTING_STARTED NEWS README* HELP_WANTED THANKS INSTALL
+ find doc/docs/man -type f | xargs doman
+ find doc/docs/texinfo -type f | xargs doinfo
+ dobin "${WORKDIR}"/3rdparty/{sff_extract,*.pl}
+}