summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/acml/acml-4.0.1.ebuild')
-rw-r--r--sci-libs/acml/acml-4.0.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-libs/acml/acml-4.0.1.ebuild b/sci-libs/acml/acml-4.0.1.ebuild
index 7dd177477d40..a1a80bc1e531 100644
--- a/sci-libs/acml/acml-4.0.1.ebuild
+++ b/sci-libs/acml/acml-4.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-4.0.1.ebuild,v 1.1 2007/12/19 02:19:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-4.0.1.ebuild,v 1.2 2007/12/19 13:03:51 bicatali Exp $
inherit eutils toolchain-funcs fortran
@@ -114,9 +114,10 @@ src_install() {
ESELECT_PROF=${ESELECT_PROF}-int64
extflags="${extflags} -fdefault-integer-8"
fi
+ [[ ${fort} =~ gfortran ]] && extlibs="${extlibs} -lgfortran"
if [[ ${fort} =~ _mp ]]; then
ESELECT_PROF=${ESELECT_PROF}-openmp
- #extlibs=-lpthread
+ extlibs="${extlibs} -lpthread"
libname=${libname}_mp
extflags="${extflags} -fopenmp"
fi
@@ -124,7 +125,7 @@ src_install() {
# pkgconfig files
sed -e "s:@LIBDIR@:$(get_libdir):" \
-e "s:@PV@:${PV}:" \
- -e "s:@ACMLDIR@:${acmldir}:g" \
+ -e "s:@ACMLDIR@:${acmldir}/lib:g" \
-e "s:@EXTLIBS@:${extlibs}:g" \
-e "s:@EXTFLAGS@:${extflags}:g" \
"${FILESDIR}"/${l}.pc.in > ${l}.pc \