summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/rkward/rkward-0.5.6-r1.ebuild')
-rw-r--r--sci-mathematics/rkward/rkward-0.5.6-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-mathematics/rkward/rkward-0.5.6-r1.ebuild b/sci-mathematics/rkward/rkward-0.5.6-r1.ebuild
new file mode 100644
index 000000000000..eda388953826
--- /dev/null
+++ b/sci-mathematics/rkward/rkward-0.5.6-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rkward/rkward-0.5.6-r1.ebuild,v 1.1 2011/08/11 20:51:09 dilfridge Exp $
+
+EAPI=4
+
+KDE_DOC_DIRS="doc"
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="ca cs da de el es fr it lt pl tr zh_CN"
+inherit kde4-base
+
+DESCRIPTION="An IDE/GUI for the R-project"
+HOMEPAGE="http://rkward.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rkward/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-lang/R"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.5.6-focus.patch" )
+
+src_install() {
+ kde4-base_src_install
+ # avoid file collisions
+ rm -f "${ED}"/usr/$(get_libdir)/R/library/R.css
+ rm -f "${ED}"/usr/share/apps/katepart/syntax/r.xml
+}