summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/iproute2/iproute2-3.8.0.ebuild')
-rw-r--r--sys-apps/iproute2/iproute2-3.8.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-apps/iproute2/iproute2-3.8.0.ebuild b/sys-apps/iproute2/iproute2-3.8.0.ebuild
index cafc8ebc786e..d9c1ec1ad03f 100644
--- a/sys-apps/iproute2/iproute2-3.8.0.ebuild
+++ b/sys-apps/iproute2/iproute2-3.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-3.8.0.ebuild,v 1.11 2013/04/27 09:57:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-3.8.0.ebuild,v 1.12 2013/04/28 17:07:14 vapier Exp $
EAPI="4"
@@ -11,7 +11,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-2
else
SRC_URI="mirror://kernel/linux/utils/net/${PN}/${P}.tar.xz"
- KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+ KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
fi
DESCRIPTION="kernel routing and traffic control utilities"
@@ -101,6 +101,10 @@ src_install() {
dolib.a lib/libnetlink.a
insinto /usr/include
doins include/libnetlink.h
+ # This local header pulls in a lot of linux headers it
+ # doesn't directly need. Delete this header that requires
+ # linux-headers-3.8 until that goes stable. #467716
+ sed -i '/linux\/netconf.h/d' "${ED}"/usr/include/libnetlink.h || die
if use berkdb ; then
dodir /var/lib/arpd