summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/suspend2-userui/suspend2-userui-0.6.2.ebuild')
-rw-r--r--sys-apps/suspend2-userui/suspend2-userui-0.6.2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/suspend2-userui/suspend2-userui-0.6.2.ebuild b/sys-apps/suspend2-userui/suspend2-userui-0.6.2.ebuild
new file mode 100644
index 000000000000..013d880a6c38
--- /dev/null
+++ b/sys-apps/suspend2-userui/suspend2-userui-0.6.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/suspend2-userui/suspend2-userui-0.6.2.ebuild,v 1.1 2005/12/27 21:58:29 brix Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="User Interface for Software Suspend 2"
+HOMEPAGE="http://www.suspend2.net"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="fbsplash"
+DEPEND="virtual/libc
+ fbsplash? ( sys-libs/zlib
+ media-libs/freetype
+ media-libs/jpeg
+ media-libs/lcms
+ >=media-libs/libmng-1.0.5
+ media-libs/libpng )"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" suspend2ui_text \
+ || die "emake userui_text failed"
+
+ if use fbsplash; then
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" fbsplash \
+ || die "emake fbsplash failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" suspend2ui_fbsplash \
+ || die "emake userui_fbsplash failed"
+ fi
+}
+
+src_install() {
+ into /
+ dosbin suspend2ui_text
+ use fbsplash && dosbin suspend2ui_fbsplash
+
+ dodoc AUTHORS ChangeLog KERNEL_API README TODO USERUI_API
+}
+
+pkg_postinst() {
+ if use fbsplash; then
+ einfo
+ einfo "You must create a symlink from /etc/splash/suspend2"
+ einfo "to the theme you want userui_fbsplash to use, e.g.:"
+ einfo
+ einfo " # ln -sfn /etc/splash/emergence /etc/splash/suspend2"
+ fi
+
+ einfo
+ einfo "Please see /usr/share/doc/${PF}/README.gz for further"
+ einfo "instructions."
+ einfo
+}