summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/tcb')
-rw-r--r--sys-apps/tcb/ChangeLog9
-rw-r--r--sys-apps/tcb/files/digest-tcb-0.9.8.81
-rw-r--r--sys-apps/tcb/tcb-0.9.8.8.ebuild33
3 files changed, 41 insertions, 2 deletions
diff --git a/sys-apps/tcb/ChangeLog b/sys-apps/tcb/ChangeLog
index 66ef69077260..b5e7466728d7 100644
--- a/sys-apps/tcb/ChangeLog
+++ b/sys-apps/tcb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/tcb
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tcb/ChangeLog,v 1.6 2004/10/02 15:33:32 swegener Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tcb/ChangeLog,v 1.7 2005/07/17 13:36:45 vapier Exp $
+
+*tcb-0.9.8.8 (17 Jul 2005)
+
+ 17 Jul 2005; Mike Frysinger <vapier@gentoo.org> +tcb-0.9.8.8.ebuild:
+ Version bump.
*tcb-0.9.8.7 (08 Jan 2004)
diff --git a/sys-apps/tcb/files/digest-tcb-0.9.8.8 b/sys-apps/tcb/files/digest-tcb-0.9.8.8
new file mode 100644
index 000000000000..2c3c043fb7d8
--- /dev/null
+++ b/sys-apps/tcb/files/digest-tcb-0.9.8.8
@@ -0,0 +1 @@
+MD5 bd0a10c89c1592a600f9e3d2185b012f tcb-0.9.8.8.tar.gz 36660
diff --git a/sys-apps/tcb/tcb-0.9.8.8.ebuild b/sys-apps/tcb/tcb-0.9.8.8.ebuild
new file mode 100644
index 000000000000..a680ef530631
--- /dev/null
+++ b/sys-apps/tcb/tcb-0.9.8.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tcb/tcb-0.9.8.8.ebuild,v 1.1 2005/07/17 13:36:45 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Libraries and tools implementing the tcb password shadowing scheme"
+HOMEPAGE="http://www.openwall.com/"
+SRC_URI="ftp://ftp.openwall.com/pub/projects/tcb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/pam-0.75"
+
+pkg_setup() {
+ # might want to add these into baselayout eventually...
+ for group in auth chkpwd shadow ; do
+ enewgroup ${group}
+ done
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ einfo "You must now run /sbin/tcb_convert to convert your shadow to tcb"
+ einfo "To remove this you must first run /sbin/tcp_unconvert and then unmerge"
+}