summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sandbox/sandbox-1.2.3.ebuild30
1 files changed, 12 insertions, 18 deletions
diff --git a/sys-apps/sandbox/sandbox-1.2.3.ebuild b/sys-apps/sandbox/sandbox-1.2.3.ebuild
index 7f63068468df..96223f6de95a 100644
--- a/sys-apps/sandbox/sandbox-1.2.3.ebuild
+++ b/sys-apps/sandbox/sandbox-1.2.3.ebuild
@@ -1,30 +1,30 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.3.ebuild,v 1.1 2005/04/29 13:47:44 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.3.ebuild,v 1.2 2005/04/29 22:17:57 vapier Exp $
-inherit eutils flag-o-matic eutils toolchain-funcs multilib
#
# don't monkey with this ebuild unless contacting portage devs.
# period.
#
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+
DESCRIPTION="sandbox'd LD_PRELOAD hack"
SRC_URI="mirror://gentoo/${P}.tar.bz2
http://dev.gentoo.org/~azarah/sandbox/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
+#KEYWORDS=" alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 s390 sh sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE=""
RESTRICT="multilib-pkg-force"
-#KEYWORDS=" alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 s390 sh sparc x86"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
-
DEPEND="virtual/libc"
check_multilib() {
has_m32
- if [ "$?" == 0 ]; then
+ if [ "$?" == 0 ] ; then
einfo "Found valid multilib environment."
einfo "Building with multilib support."
export MULTILIB="1"
@@ -38,24 +38,20 @@ check_multilib() {
}
src_unpack() {
- if has_multilib_profile; then
+ if has_multilib_profile ; then
for TA in $(get_install_abis); do
- unpack ${A} || die "unpack failed"
- cd ${S}
- epunt_cxx
+ unpack ${A}
cd ${WORKDIR}
mv ${S} ${S%/}-${TA} || die "failed mving \$S to $TA"
done
else
- unpack ${A} || die "unpack failed"
- cd ${S}
- epunt_cxx
+ unpack ${A}
fi
}
src_compile() {
filter-lfs-flags #90228
- if has_multilib_profile; then
+ if has_multilib_profile ; then
OABI="${ABI}"
export CFLAGS="${CFLAGS} -DSB_HAVE_64BIT_ARCH"
for ABI in $(get_install_abis); do
@@ -66,11 +62,10 @@ src_compile() {
done
ABI="${OABI}"
else
- if useq amd64; then
+ if useq amd64 ; then
check_multilib
export HAVE_64BIT_ARCH="${MULTILIB}"
fi
- cd ${S}
econf || die "econf failed"
emake || die "emake failed"
fi
@@ -86,7 +81,6 @@ src_install() {
done
ABI="${OABI}"
else
- cd ${S}
- einstall || die "einstalled failed"
+ make install DESTDIR="${D}" || die "einstalled failed"
fi
}