summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/plymouth/plymouth-0.8.3.ebuild')
-rw-r--r--sys-boot/plymouth/plymouth-0.8.3.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/sys-boot/plymouth/plymouth-0.8.3.ebuild b/sys-boot/plymouth/plymouth-0.8.3.ebuild
index a0160672df23..cdf9c4d54a44 100644
--- a/sys-boot/plymouth/plymouth-0.8.3.ebuild
+++ b/sys-boot/plymouth/plymouth-0.8.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/plymouth-0.8.3.ebuild,v 1.2 2011/02/21 21:54:33 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/plymouth-0.8.3.ebuild,v 1.3 2011/03/04 22:22:12 aidecoe Exp $
-EAPI="3"
+EAPI=3
inherit autotools-utils
@@ -28,6 +28,8 @@ RDEPEND="${DEPEND}
>=sys-kernel/dracut-007
"
+DOCS=(AUTHORS ChangeLog NEWS README TODO)
+
PATCHES=(
"${FILESDIR}"/${PV}-drm-reduce-minimum-build-requirements.patch
"${FILESDIR}"/${PV}-image-replace-deprecated-libpng-function.patch
@@ -36,18 +38,19 @@ PATCHES=(
src_prepare() {
autotools-utils_src_prepare
- eautoreconf || die "eautoreconf failed"
+ eautoreconf
}
src_configure() {
- econf \
- --enable-static=no \
- $(use_enable pango) \
- $(use_enable gdm gdm-transition) \
- $(use_enable video_cards_intel libdrm_intel) \
- $(use_enable video_cards_nouveau libdrm_nouveau) \
- $(use_enable video_cards_radeon libdrm_radeon) \
- || die "econf failed"
+ local myeconfargs=(
+ --enable-static=no
+ $(use_enable pango)
+ $(use_enable gdm gdm-transition)
+ $(use_enable video_cards_intel libdrm_intel)
+ $(use_enable video_cards_nouveau libdrm_nouveau)
+ $(use_enable video_cards_radeon libdrm_radeon)
+ )
+ autotools-utils_src_configure
}
src_install() {