summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/corosync/files')
-rw-r--r--sys-cluster/corosync/files/corosync-2.0.0-docs.patch36
-rw-r--r--sys-cluster/corosync/files/corosync-2.0.0-rpath.patch33
2 files changed, 69 insertions, 0 deletions
diff --git a/sys-cluster/corosync/files/corosync-2.0.0-docs.patch b/sys-cluster/corosync/files/corosync-2.0.0-docs.patch
new file mode 100644
index 000000000000..68de1f1b546d
--- /dev/null
+++ b/sys-cluster/corosync/files/corosync-2.0.0-docs.patch
@@ -0,0 +1,36 @@
+Make docs optional
+
+--- configure.ac
++++ configure.ac
+@@ -432,7 +432,7 @@
+ fi
+
+ # final build of *FLAGS
+-CFLAGS="$ENV_CFLAGS $OPT_CFLAGS $GDB_FLAGS $OS_CFLAGS \
++CFLAGS="$ENV_CFLAGS $OS_CFLAGS \
+ $COVERAGE_CFLAGS $EXTRA_WARNINGS $WERROR_CFLAGS $NSS_CFLAGS"
+ CPPFLAGS="$ENV_CPPFLAGS $ANSI_CPPFLAGS $OS_CPPFLAGS"
+ LDFLAGS="$ENV_LDFLAGS $COVERAGE_LDFLAGS $OS_LDFLAGS"
+@@ -458,7 +458,10 @@
+ AC_SUBST([DARWIN_OPTS])
+ AC_SUBST([SOLARIS_OPTS])
+
+-AM_CONDITIONAL(BUILD_HTML_DOCS, test -n "${GROFF}")
++AC_ARG_ENABLE([doc],
++ AS_HELP_STRING([--enable-doc],[Build html documentation])
++)
++AM_CONDITIONAL(BUILD_HTML_DOCS, [test -n "${GROFF}" && test "x$enable_doc" = "xyes"] )
+
+ AC_SUBST([LINT_FLAGS])
+
+--- Makefile.am
++++ Makefile.am
+@@ -46,8 +46,6 @@
+ config.guess config.sub missing install-sh \
+ autoheader automake autoconf test_lense.sh
+
+-dist_doc_DATA = LICENSE INSTALL README.recovery SECURITY TODO AUTHORS
+-
+ SUBDIRS = include common_lib lib exec tools test cts pkgconfig \
+ man init conf
+
diff --git a/sys-cluster/corosync/files/corosync-2.0.0-rpath.patch b/sys-cluster/corosync/files/corosync-2.0.0-rpath.patch
new file mode 100644
index 000000000000..4cca805066d8
--- /dev/null
+++ b/sys-cluster/corosync/files/corosync-2.0.0-rpath.patch
@@ -0,0 +1,33 @@
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -49,7 +49,7 @@
+
+ EXTRA_DIST = $(bin_SCRIPTS) corosync-xmlproc.sh corosync-notifyd.sysconfig.example
+
+-COMMON_OPTS = -L../lib -L../common_lib -Wl,-rpath,../common_lib
++COMMON_OPTS = -L../lib -L../common_lib
+
+ corosync_cmapctl_LDFLAGS= $(COMMON_OPTS)
+ corosync_cmapctl_LDADD = -lcorosync_common -lcmap $(LIBQB_LIBS)
+@@ -57,10 +57,10 @@
+ corosync_fplay_LDADD = $(LIBQB_LIBS)
+
+ corosync_cfgtool_LDFLAGS= $(COMMON_OPTS)
+-corosync_cfgtool_LDADD = -lcfg $(LIBQB_LIBS)
++corosync_cfgtool_LDADD = -lcfg -lcorosync_common $(LIBQB_LIBS)
+
+ corosync_cpgtool_LDFLAGS= $(COMMON_OPTS)
+-corosync_cpgtool_LDADD = -lcfg -lcpg $(LIBQB_LIBS)
++corosync_cpgtool_LDADD = -lcfg -lcpg -lcorosync_common $(LIBQB_LIBS)
+
+ corosync_quorumtool_LDFLAGS = $(COMMON_OPTS)
+ corosync_quorumtool_LDADD = -lcmap -lcfg -lquorum -lcorosync_common \
+@@ -68,7 +68,7 @@
+
+ corosync_notifyd_CPPFLAGS = $(DBUS_CFLAGS)
+ corosync_notifyd_LDFLAGS = $(COMMON_OPTS)
+-corosync_notifyd_LDADD = -lcfg -lcmap \
++corosync_notifyd_LDADD = -lcfg -lcmap -lcorosync_common \
+ $(LIBQB_LIBS) $(DBUS_LIBS) $(SNMPLIBS) \
+ -lquorum
+