summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/binutils/binutils-2.15.92.0.2-r5.ebuild')
-rw-r--r--sys-devel/binutils/binutils-2.15.92.0.2-r5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/binutils/binutils-2.15.92.0.2-r5.ebuild b/sys-devel/binutils/binutils-2.15.92.0.2-r5.ebuild
new file mode 100644
index 000000000000..8a485ae0d72b
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.15.92.0.2-r5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.92.0.2-r5.ebuild,v 1.1 2005/03/09 02:37:57 vapier Exp $
+
+PATCHVER="1.6"
+UCLIBC_PATCHVER="1.1"
+inherit toolchain-binutils
+
+KEYWORDS="-* ~alpha ~amd64 -arm ~hppa -ia64 ~sparc ~x86"
+
+src_unpack() {
+ toolchain-binutils_src_unpack
+
+ # Patches
+ cd ${WORKDIR}/patch
+ mkdir skip
+ mv *ldsoconf* *no_rel_ro* skip/
+ if use uclibc ; then
+ mv *relro* skip/
+ else
+ mv 20_* skip/
+ fi
+
+ apply_binutils_updates
+}