summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/ddrescue/ddrescue-1.17.ebuild')
-rw-r--r--sys-fs/ddrescue/ddrescue-1.17.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-fs/ddrescue/ddrescue-1.17.ebuild b/sys-fs/ddrescue/ddrescue-1.17.ebuild
new file mode 100644
index 000000000000..d42f57f3ece5
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.17.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ddrescue-1.17.ebuild,v 1.1 2013/09/19 08:42:17 polynomial-c Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Copies data from one file or block device to another with read-error recovery"
+HOMEPAGE="http://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE=""
+
+DEPEND="app-arch/lzip"
+RDEPEND=""
+
+src_unpack() {
+ # Upstream only provides an lzip compressed tarball for this version
+ tar --lzip -xf "${DISTDIR}"/${P}.tar.lz || die
+}
+
+src_configure() {
+ # not a normal configure script
+ econf \
+ --prefix="${EPREFIX}"/usr \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ ./testsuite/check.sh "${S}"/testsuite || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man
+ dodoc ChangeLog README NEWS AUTHORS
+}