summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/device-mapper/device-mapper-1.02.10.ebuild')
-rw-r--r--sys-fs/device-mapper/device-mapper-1.02.10.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/sys-fs/device-mapper/device-mapper-1.02.10.ebuild b/sys-fs/device-mapper/device-mapper-1.02.10.ebuild
deleted file mode 100644
index 097e95748ae5..000000000000
--- a/sys-fs/device-mapper/device-mapper-1.02.10.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/device-mapper-1.02.10.ebuild,v 1.5 2006/10/30 02:01:46 weeve Exp $
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="Device mapper ioctl library for use with LVM2 utilities"
-HOMEPAGE="http://sources.redhat.com/dm/"
-SRC_URI="ftp://sources.redhat.com/pub/dm/${PN}.${PV}.tgz
- ftp://sources.redhat.com/pub/dm/old/${PN}.${PV}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 arm ~hppa ia64 m68k ~mips ppc ~ppc64 s390 sh sparc x86"
-IUSE="selinux"
-
-DEPEND="selinux? ( sys-libs/libselinux )"
-
-S=${WORKDIR}/${PN}.${PV}
-
-src_compile() {
- econf --sbindir=/sbin $(use_enable selinux) || die "econf failed"
- emake || die "compile problem"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
-
- # move shared libs to /
- mv "${D}"/usr/$(get_libdir) "${D}"/ || die "move libdir"
- dolib.a lib/ioctl/libdevmapper.a || die "dolib.a"
- gen_usr_ldscript libdevmapper.so
-
- insinto /etc
- doins "${FILESDIR}"/dmtab
- insinto /lib/rcscripts/addons
- doins "${FILESDIR}"/dm-start.sh
-
- dodoc INSTALL INTRO README VERSION WHATS_NEW
-}
-
-pkg_preinst() {
- local l=${ROOT}/$(get_libdir)/libdevmapper.so.1.01
- [[ -e ${l} ]] && cp "${l}" "${D}"/$(get_libdir)/
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/libdevmapper.so.1.01
-}