summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/loop-aes/loop-aes-3.2e.ebuild')
-rw-r--r--sys-fs/loop-aes/loop-aes-3.2e.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/sys-fs/loop-aes/loop-aes-3.2e.ebuild b/sys-fs/loop-aes/loop-aes-3.2e.ebuild
index c931049cb9b6..c50f48ee8f75 100644
--- a/sys-fs/loop-aes/loop-aes-3.2e.ebuild
+++ b/sys-fs/loop-aes/loop-aes-3.2e.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/loop-aes/loop-aes-3.2e.ebuild,v 1.1 2008/11/06 08:20:45 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/loop-aes/loop-aes-3.2e.ebuild,v 1.2 2009/03/08 14:59:19 betelgeuse Exp $
+
+EAPI="2"
inherit linux-mod
@@ -15,17 +17,12 @@ IUSE="keyscrub padlock"
KEYWORDS="~amd64 ~hppa ~ppc ~x86"
RDEPEND=">=sys-apps/util-linux-2.12r"
+RDEPEND="|| ( ${RDEPEND}[crypt] ${RDEPEND}[loop-aes] )"
DEPEND=""
S="${WORKDIR}/${MY_P}"
pkg_setup() {
- if ! built_with_use sys-apps/util-linux crypt && \
- ! built_with_use sys-apps/util-linux loop-aes; then
- eerror "loop-aes needs >=util-linux-2.12q-r1 compiled with crypt or loop-aes use-flag enabled!"
- die "util-linux without crypt detected"
- fi
-
linux-mod_pkg_setup
CONFIG_CHECK="!BLK_DEV_LOOP"
@@ -43,7 +40,7 @@ pkg_setup() {
src_install() {
linux-mod_src_install
- dodoc README
+ dodoc README || die
dobin loop-aes-keygen
doman loop-aes-keygen.1
}