summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/reiser4progs/reiser4progs-1.0.0.ebuild')
-rw-r--r--sys-fs/reiser4progs/reiser4progs-1.0.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-fs/reiser4progs/reiser4progs-1.0.0.ebuild b/sys-fs/reiser4progs/reiser4progs-1.0.0.ebuild
new file mode 100644
index 000000000000..519f50daa39f
--- /dev/null
+++ b/sys-fs/reiser4progs/reiser4progs-1.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiser4progs/reiser4progs-1.0.0.ebuild,v 1.1 2004/08/14 08:58:23 vapier Exp $
+
+DESCRIPTION="reiser4progs: mkfs, fsck, etc..."
+HOMEPAGE="http://www.namesys.com/v4/v4.html"
+SRC_URI="http://thebsh.namesys.com/pub/reiser4progs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc amd64"
+IUSE="static debug readline"
+
+DEPEND=">=sys-libs/libaal-1.0.0
+ readline? ( sys-libs/readline )"
+
+src_compile() {
+ econf \
+ `use_enable static full-static` \
+ `use_enable static mkfs-static` \
+ `use_enable static fsck-static` \
+ `use_enable static debugfs-static` \
+ `use_enable static measurefs-static` \
+ `use_enable static cpfs-static` \
+ `use_enable static resizefs-static` \
+ `use_enable debug` \
+ `use_with readline` \
+ --enable-stand-alone \
+ --sbindir=/sbin \
+ --libdir=/lib \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS CREDITS ChangeLog NEWS README THANKS TODO
+
+ # move stupid .a out of root
+ dodir /usr/lib
+ local l=""
+ for l in libreiser4-alone libreiser4 librepair ; do
+ mv ${D}/lib/${l}.{a,la} ${D}/usr/lib/
+ dosym ../usr/lib/${l}.a /lib/${l}.a
+ done
+}