summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/davl/ChangeLog9
-rw-r--r--sys-fs/davl/davl-1.2.4.ebuild20
2 files changed, 17 insertions, 12 deletions
diff --git a/sys-fs/davl/ChangeLog b/sys-fs/davl/ChangeLog
index e64b45f90bcf..942f8bb7d8c3 100644
--- a/sys-fs/davl/ChangeLog
+++ b/sys-fs/davl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/davl
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/davl/ChangeLog,v 1.6 2012/01/14 18:24:19 armin76 Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/davl/ChangeLog,v 1.7 2014/05/12 09:32:14 ssuominen Exp $
+
+ 12 May 2014; Samuli Suominen <ssuominen@gentoo.org> davl-1.2.4.ebuild:
+ Convert from EAPI1 to EAPI5 and respect CC from environment instead of using
+ plain "cc"
*davl-1.2.4 (14 Jan 2012)
@@ -24,4 +28,3 @@
+davl-1.2.1.ebuild:
Initial import, bug 120182, thanks to Paul Bredbury <brebs at sent dot com>
for the initial ebuild
-
diff --git a/sys-fs/davl/davl-1.2.4.ebuild b/sys-fs/davl/davl-1.2.4.ebuild
index 367f5bee2972..3b916084d96c 100644
--- a/sys-fs/davl/davl-1.2.4.ebuild
+++ b/sys-fs/davl/davl-1.2.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/davl/davl-1.2.4.ebuild,v 1.1 2012/01/14 18:24:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/davl/davl-1.2.4.ebuild,v 1.2 2014/05/12 09:32:14 ssuominen Exp $
-EAPI=1
-inherit eutils
+EAPI=5
+inherit eutils toolchain-funcs
DESCRIPTION="Visualizes the fragmentation status of ext2/3 filesystems"
HOMEPAGE="http://davl.sourceforge.net/"
@@ -16,16 +16,18 @@ IUSE=""
RDEPEND=">=x11-libs/gtk+-2.6:2"
DEPEND="${RDEPEND}
->=sys-fs/e2fsprogs-1.38"
+ >=sys-fs/e2fsprogs-1.38"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-1.2.1-asneeded.patch
}
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
src_install() {
- dobin src/cdavl/cdavl src/gdavl/gdavl
+ dobin src/{cdavl/cdavl,gdavl/gdavl}
dodoc README
doman doc/*.8
}