summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/newlib/newlib-1.20.0.ebuild')
-rw-r--r--sys-libs/newlib/newlib-1.20.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/newlib/newlib-1.20.0.ebuild b/sys-libs/newlib/newlib-1.20.0.ebuild
index 87b03629ceee..37d6b9a04f56 100644
--- a/sys-libs/newlib/newlib-1.20.0.ebuild
+++ b/sys-libs/newlib/newlib-1.20.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.20.0.ebuild,v 1.5 2013/02/09 04:40:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.20.0.ebuild,v 1.6 2015/02/27 08:01:12 vapier Exp $
EAPI="4"
@@ -9,8 +9,8 @@ inherit eutils flag-o-matic toolchain-funcs
export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
fi
fi