summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/newlib/newlib-2.2.0.ebuild')
-rw-r--r--sys-libs/newlib/newlib-2.2.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-libs/newlib/newlib-2.2.0.ebuild b/sys-libs/newlib/newlib-2.2.0.ebuild
index 6f585716c6b1..44ddeb65dc75 100644
--- a/sys-libs/newlib/newlib-2.2.0.ebuild
+++ b/sys-libs/newlib/newlib-2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-2.2.0.ebuild,v 1.1 2015/02/17 07:03:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-2.2.0.ebuild,v 1.2 2015/02/27 08:01:12 vapier Exp $
EAPI="4"
@@ -17,8 +17,8 @@ fi
export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
fi
fi