summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/audit')
-rw-r--r--sys-process/audit/ChangeLog6
-rw-r--r--sys-process/audit/audit-2.0.5.ebuild4
-rw-r--r--sys-process/audit/files/audit-2.0.5-python.patch22
3 files changed, 29 insertions, 3 deletions
diff --git a/sys-process/audit/ChangeLog b/sys-process/audit/ChangeLog
index 9a9a3fb8247e..439ff0b9364b 100644
--- a/sys-process/audit/ChangeLog
+++ b/sys-process/audit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/audit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/ChangeLog,v 1.62 2011/01/25 03:52:32 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/ChangeLog,v 1.63 2011/02/07 21:00:11 arfrever Exp $
+
+ 07 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ audit-2.0.5.ebuild, +files/audit-2.0.5-python.patch:
+ Don't install auparse.a in Python site-packages directories.
25 Jan 2011; Robin H. Johnson <robbat2@gentoo.org> audit-1.7.3.ebuild,
audit-1.7.4.ebuild, audit-1.7.9.ebuild, audit-1.7.17.ebuild:
diff --git a/sys-process/audit/audit-2.0.5.ebuild b/sys-process/audit/audit-2.0.5.ebuild
index e6fc864ace6f..77a406a4add4 100644
--- a/sys-process/audit/audit-2.0.5.ebuild
+++ b/sys-process/audit/audit-2.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/audit-2.0.5.ebuild,v 1.1 2011/01/25 03:35:01 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/audit-2.0.5.ebuild,v 1.2 2011/02/07 21:00:11 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -65,7 +65,7 @@ src_prepare() {
fi
# Don't build static version of Python module.
- epatch "${FILESDIR}"/${PN}-1.7.17-python.patch
+ epatch "${FILESDIR}"/${P}-python.patch
# Regenerate autotooling
eautoreconf
diff --git a/sys-process/audit/files/audit-2.0.5-python.patch b/sys-process/audit/files/audit-2.0.5-python.patch
new file mode 100644
index 000000000000..29742ab5c5e4
--- /dev/null
+++ b/sys-process/audit/files/audit-2.0.5-python.patch
@@ -0,0 +1,22 @@
+--- bindings/python/Makefile.am
++++ bindings/python/Makefile.am
+@@ -27,5 +27,6 @@
+
+ auparse_la_SOURCES = auparse_python.c
+ auparse_la_CPPFLAGS = -I$(top_srcdir)/auparse $(AM_CPPFLAGS) -I/usr/include/python$(PYTHON_VERSION) -fno-strict-aliasing
+-auparse_la_LDFLAGS = -module -avoid-version
++auparse_la_CFLAGS = -shared
++auparse_la_LDFLAGS = -module -avoid-version -shared
+ auparse_la_LIBADD = ../../auparse/libauparse.la ../../lib/libaudit.la
+--- swig/Makefile.am
++++ swig/Makefile.am
+@@ -28,7 +28,8 @@
+ pyexec_PYTHON = audit.py
+ pyexec_LTLIBRARIES = _audit.la
+ pyexec_SOLIBRARIES = _audit.so
+-_audit_la_LDFLAGS = -module -avoid-version
++_audit_la_CFLAGS = -shared
++_audit_la_LDFLAGS = -module -avoid-version -shared
+ _audit_la_HEADERS: $(top_builddir)/config.h
+ _audit_la_DEPENDENCIES =${top_srcdir}/lib/libaudit.h ${top_builddir}/lib/libaudit.la
+ nodist__audit_la_SOURCES = audit_wrap.c