summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/htop/htop-0.6.6.ebuild')
-rw-r--r--sys-process/htop/htop-0.6.6.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sys-process/htop/htop-0.6.6.ebuild b/sys-process/htop/htop-0.6.6.ebuild
index 38ecb1cf98b4..a4fb2ee5365a 100644
--- a/sys-process/htop/htop-0.6.6.ebuild
+++ b/sys-process/htop/htop-0.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.6.6.ebuild,v 1.7 2007/08/13 21:59:25 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.6.6.ebuild,v 1.8 2007/08/16 13:44:15 angelos Exp $
inherit flag-o-matic
@@ -13,6 +13,16 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
DEPEND="sys-libs/ncurses"
+pkg_setup() {
+ if use elibc_FreeBSD ; then
+ elog
+ elog "htop needs /proc mounted to work, to mount it type"
+ elog "mount -t linprocfs none /proc"
+ elog "or uncomment the example in /etc/fstab"
+ elog
+ fi
+}
+
src_compile() {
useq debug && append-flags -O -ggdb -DDEBUG
econf || die "configure failed"