summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/ruby/ruby-1.ebuild')
-rw-r--r--virtual/ruby/ruby-1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/virtual/ruby/ruby-1.ebuild b/virtual/ruby/ruby-1.ebuild
new file mode 100644
index 000000000000..5dd1b534df19
--- /dev/null
+++ b/virtual/ruby/ruby-1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby/ruby-1.ebuild,v 1.1 2015/08/02 07:39:54 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22 rbx"
+
+inherit ruby-single
+
+DESCRIPTION="Virtual ebuild for ruby"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Ruby"
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RUBY_DEPS}"
+
+# The purpose of this ebuild is to provide a mechanism for end-users to
+# install the "best" ruby version on their system, based on current
+# stable versions and default RUBY_TARGETS. Other ebuilds should not
+# depend on this but instead use the ruby-single eclass.