summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/fcgiwrap/ChangeLog7
-rw-r--r--www-misc/fcgiwrap/fcgiwrap-1.1.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/www-misc/fcgiwrap/ChangeLog b/www-misc/fcgiwrap/ChangeLog
index 10cd23bcecfc..d1e64d881f6a 100644
--- a/www-misc/fcgiwrap/ChangeLog
+++ b/www-misc/fcgiwrap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-misc/fcgiwrap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/ChangeLog,v 1.13 2013/02/16 13:06:52 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/ChangeLog,v 1.14 2013/02/18 19:10:11 hwoarang Exp $
+
+*fcgiwrap-1.1.0 (18 Feb 2013)
+
+ 18 Feb 2013; Markos Chandras <hwoarang@gentoo.org> +fcgiwrap-1.1.0.ebuild:
+ Version bump. Thanks to Manuel Rüger (mrueg) <gentoo@rueg.eu>. Bug #456038
16 Feb 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #96436
diff --git a/www-misc/fcgiwrap/fcgiwrap-1.1.0.ebuild b/www-misc/fcgiwrap/fcgiwrap-1.1.0.ebuild
new file mode 100644
index 000000000000..72815c9626fa
--- /dev/null
+++ b/www-misc/fcgiwrap/fcgiwrap-1.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/fcgiwrap-1.1.0.ebuild,v 1.1 2013/02/18 19:10:11 hwoarang Exp $
+
+EAPI="4"
+
+[[ ${PV} = *9999* ]] && VCS_ECLASS="git" || VCS_ECLASS=""
+inherit autotools toolchain-funcs ${VCS_ECLASS}
+
+DESCRIPTION="Simple FastCGI wrapper for CGI scripts (CGI support for nginx)"
+HOMEPAGE="http://nginx.localdomain.pl/wiki/FcgiWrap"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/gnosek/${PN}.git"
+
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/gnosek/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="dev-libs/fcgi"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README.rst )
+
+src_prepare() {
+ sed -e '/man8dir = $(DESTDIR)/s/@prefix@//' \
+ -i Makefile.in || die "sed failed"
+ tc-export CC
+ eautoreconf
+}
+
+pkg_postinst() {
+ einfo 'You may want to install www-servers/spawn-fcgi to use with fcgiwrap.'
+}