summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/lighttpd/files/1.4.1/02_all_optional_pcre.diff')
-rw-r--r--www-servers/lighttpd/files/1.4.1/02_all_optional_pcre.diff16
1 files changed, 16 insertions, 0 deletions
diff --git a/www-servers/lighttpd/files/1.4.1/02_all_optional_pcre.diff b/www-servers/lighttpd/files/1.4.1/02_all_optional_pcre.diff
new file mode 100644
index 000000000000..ed569147cb8c
--- /dev/null
+++ b/www-servers/lighttpd/files/1.4.1/02_all_optional_pcre.diff
@@ -0,0 +1,16 @@
+--- configure.in.orig 2005-08-24 02:40:58.000000000 -0400
++++ configure.in 2005-08-24 02:51:01.000000000 -0400
+@@ -217,7 +217,12 @@
+ AC_SUBST(SSL_LIB)
+ fi
+
+-if test "x$cross_compiling" = xno; then
++AC_MSG_CHECKING(for perl regular expressions support)
++AC_ARG_WITH(pcre, AC_HELP_STRING([--with-pcre],[Enable pcre support (default yes)]),
++ [WITH_PCRE=$withval],[WITH_PCRE=yes])
++AC_MSG_RESULT([$WITH_PCRE])
++
++if test "x$cross_compiling" = xno -a "$WITH_PCRE" != "no"; then
+ AC_PATH_PROG(PCRECONFIG, pcre-config)
+
+ if test x"$PCRECONFIG" != x; then