summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libview')
-rw-r--r--x11-libs/libview/ChangeLog9
-rw-r--r--x11-libs/libview/libview-0.6.6.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/x11-libs/libview/ChangeLog b/x11-libs/libview/ChangeLog
index 8ff5018b1329..d40184812826 100644
--- a/x11-libs/libview/ChangeLog
+++ b/x11-libs/libview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libview
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libview/ChangeLog,v 1.10 2009/01/15 23:12:01 loki_val Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libview/ChangeLog,v 1.11 2010/09/02 12:57:40 vadimk Exp $
+
+*libview-0.6.6 (02 Sep 2010)
+
+ 02 Sep 2010; Vadim Kuznetsov <vadimk@gentoo.org> +libview-0.6.6.ebuild:
+ version bump
15 Jan 2009; Peter Alfredsen <loki_val@gentoo.org> metadata.xml:
Compnerd retired.
diff --git a/x11-libs/libview/libview-0.6.6.ebuild b/x11-libs/libview/libview-0.6.6.ebuild
new file mode 100644
index 000000000000..af3917ce168a
--- /dev/null
+++ b/x11-libs/libview/libview-0.6.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libview/libview-0.6.6.ebuild,v 1.1 2010/09/02 12:57:40 vadimk Exp $
+
+EAPI=3
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="VMware's Incredibly Exciting Widgets"
+HOMEPAGE="http://view.sourceforge.net"
+SRC_URI="mirror://sourceforge/view/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.4.0
+ >=dev-cpp/gtkmm-2.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+G2CONF="--enable-deprecated"
+
+src_unpack() {
+ gnome2_src_unpack
+}
+
+src_prepare() {
+ # Fix the pkgconfig file
+ epatch "${FILESDIR}"/${PN}-0.5.6-pcfix.patch
+ eautoreconf -i
+}