summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/rss-glx/files/rss-glx-0.8.1-gentoo.patch')
-rw-r--r--x11-misc/rss-glx/files/rss-glx-0.8.1-gentoo.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/rss-glx/files/rss-glx-0.8.1-gentoo.patch b/x11-misc/rss-glx/files/rss-glx-0.8.1-gentoo.patch
new file mode 100644
index 000000000000..3febc2b7f86f
--- /dev/null
+++ b/x11-misc/rss-glx/files/rss-glx-0.8.1-gentoo.patch
@@ -0,0 +1,40 @@
+--- rss-glx_0.8.1-orig/configure.in
++++ rss-glx_0.8.1/configure.in
+@@ -7,14 +7,14 @@ AM_CONFIG_HEADER(config.h)
+ AC_PROG_AWK
+
+ AC_PROG_CC
+-CFLAGS=-g
++#CFLAGS=-g
+ AC_ARG_ENABLE([debug], [AC_HELP_STRING([--enable-debug],
+ [build with debugging information default=yes])],
+ [test "$enableval" = "no" && CFLAGS="-O2"])
+ CFLAGS="$CFLAGS -Wall"
+
+ AC_PROG_CXX
+-CXXFLAGS=-g
++#CXXFLAGS=-g
+ AC_ARG_ENABLE([debug], [AC_HELP_STRING([--enable-debug],
+ [build with debugging information default=yes])],
+ [test "$enableval" = "no" && CXXFLAGS="-O2"])
+--- rss-glx_0.8.1-orig/reallyslick/cpp_src/Makefile.am
++++ rss-glx_0.8.1/reallyslick/cpp_src/Makefile.am
+@@ -19,7 +19,7 @@ if INSTALL_XSCREENSAVER_CONFIG_FILES
+ dist_config_DATA = cyclone.xml fieldlines.xml flocks.xml flux.xml helios.xml hyperspace.xml plasma.xml skyrocket.xml solarwinds.xml
+ endif
+
+-if INSTALL_XSCREENSAVER_CONFIG_FILES
++if INSTALL_KDE_CONFIG_FILES
+ dist_kdessconfig_DATA = cyclone.desktop fieldlines.desktop flocks.desktop flux.desktop helios.desktop hyperspace.desktop plasma.desktop skyrocket.desktop solarwinds.desktop
+ endif
+
+--- rss-glx_0.8.1-orig/reallyslick/cpp_src/skyrocket.cpp
++++ rss-glx_0.8.1/reallyslick/cpp_src/skyrocket.cpp
+@@ -23,6 +23,7 @@
+ #include <GL/gl.h>
+ #include <GL/glu.h>
+
++#include <cassert>
+ #include <list>
+
+ #include "driver.h"