summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/read-edid/ChangeLog10
-rw-r--r--x11-misc/read-edid/files/read-edid-3.0.0-include.patch11
-rw-r--r--x11-misc/read-edid/files/read-edid-3.0.0-sharedir.patch10
-rw-r--r--x11-misc/read-edid/read-edid-3.0.0.ebuild29
4 files changed, 58 insertions, 2 deletions
diff --git a/x11-misc/read-edid/ChangeLog b/x11-misc/read-edid/ChangeLog
index 171ac08eeb2a..7a58ba8924d6 100644
--- a/x11-misc/read-edid/ChangeLog
+++ b/x11-misc/read-edid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/read-edid
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/read-edid/ChangeLog,v 1.26 2011/11/18 03:52:41 xmw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/read-edid/ChangeLog,v 1.27 2013/09/07 15:27:55 jer Exp $
+
+*read-edid-3.0.0 (07 Sep 2013)
+
+ 07 Sep 2013; Jeroen Roovers <jer@gentoo.org> +read-edid-3.0.0.ebuild,
+ +files/read-edid-3.0.0-include.patch, +files/read-edid-3.0.0-sharedir.patch:
+ Version bump.
18 Nov 2011; Michael Weber <xmw@gentoo.org> -read-edid-2.0.0.ebuild:
Remove old version
diff --git a/x11-misc/read-edid/files/read-edid-3.0.0-include.patch b/x11-misc/read-edid/files/read-edid-3.0.0-include.patch
new file mode 100644
index 000000000000..de3b6dbabc22
--- /dev/null
+++ b/x11-misc/read-edid/files/read-edid-3.0.0-include.patch
@@ -0,0 +1,11 @@
+--- a/get-edid/classic.c
++++ b/get-edid/classic.c
+@@ -6,6 +6,8 @@
+ #include <assert.h>
+ #include <string.h>
+ #include <sys/types.h>
++#include <sys/io.h> /* iopl() */
++#include <unistd.h> /* ioperm()/iopl() */
+
+ #include <libx86.h>
+
diff --git a/x11-misc/read-edid/files/read-edid-3.0.0-sharedir.patch b/x11-misc/read-edid/files/read-edid-3.0.0-sharedir.patch
new file mode 100644
index 000000000000..013361493859
--- /dev/null
+++ b/x11-misc/read-edid/files/read-edid-3.0.0-sharedir.patch
@@ -0,0 +1,10 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -12,5 +12,5 @@
+ endif ()
+ add_subdirectory (parse-edid)
+
+-INSTALL(FILES get-edid.man DESTINATION man)
+-INSTALL(FILES AUTHORS ChangeLog COPYING NEWS README DESTINATION doc)
++INSTALL(FILES get-edid.man DESTINATION share/man)
++INSTALL(FILES AUTHORS ChangeLog COPYING NEWS README DESTINATION share/doc)
diff --git a/x11-misc/read-edid/read-edid-3.0.0.ebuild b/x11-misc/read-edid/read-edid-3.0.0.ebuild
new file mode 100644
index 000000000000..fd58e3c4c203
--- /dev/null
+++ b/x11-misc/read-edid/read-edid-3.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/read-edid/read-edid-3.0.0.ebuild,v 1.1 2013/09/07 15:27:55 jer Exp $
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Program that can get information from a PnP monitor"
+HOMEPAGE="http://www.polypux.org/projects/read-edid/"
+SRC_URI="http://www.polypux.org/projects/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+DEPEND=">=dev-libs/libx86-1.1"
+RDEPEND="$DEPEND"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+PATCHES=(
+ "${FILESDIR}"/${P}-include.patch
+ "${FILESDIR}"/${P}-sharedir.patch
+)
+
+#src_install() {
+# default
+# # as per bug #283322
+# dobin parse-edid/parse-edid
+#}