summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/asbutton/asbutton-0.3.ebuild')
-rw-r--r--x11-plugins/asbutton/asbutton-0.3.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/x11-plugins/asbutton/asbutton-0.3.ebuild b/x11-plugins/asbutton/asbutton-0.3.ebuild
index d097783b3fcd..e7573da3a97e 100644
--- a/x11-plugins/asbutton/asbutton-0.3.ebuild
+++ b/x11-plugins/asbutton/asbutton-0.3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2.
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asbutton/asbutton-0.3.ebuild,v 1.1 2003/04/19 19:40:41 sethbc Exp $
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asbutton/asbutton-0.3.ebuild,v 1.1.1.1 2005/11/30 10:10:43 chriswhite Exp $
-S=${WORKDIR}/${P}
+inherit eutils
+
+IUSE=""
DESCRIPTION="A simple dockable application launcher for use in AfterStep."
SRC_URI="http://www.tigr.net/afterstep/download/asbutton/${P}.tar.gz"
HOMEPAGE="http://www.tigr.net"
@@ -14,20 +16,14 @@ KEYWORDS="x86"
DEPEND="virtual/x11"
src_unpack() {
- unpack ${A}
-
- cd ${S}
- patch -p0 < ${FILESDIR}/${P}-gentoo.patch || die "patch failed"
-}
-
-src_compile() {
- emake || die "emake failed"
+ unpack ${A} ; cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
}
src_install () {
dodir /usr/bin
dodir /usr/share/afterstep/desktop/icons/16bpp
- make DESTDIR=${D} install || die
+ make DESTDIR=${D} install || die
dodoc README CHANGES
}